summaryrefslogtreecommitdiff
path: root/app-text/xapian-omega
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
commitfcf991edcc1b310199e4e829a3706bc1c267d1db (patch)
tree50f02cb76c2666dbe78d927799c034715582c9cd /app-text/xapian-omega
parent3c246ed172bd795a519ba659ba32c9e91f6bedde (diff)
gentoo auto-resync : 24:09:2023 - 05:21:45
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest2
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.23.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 00ac2a71a50c..d2ea8219c68a 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -1,3 +1,5 @@
DIST xapian-omega-1.4.22.tar.xz 570476 BLAKE2B 05bd5c8135870b3a2058bcd032da9609cac7d0b1a07b31cb84f8fdf175bb87d22acd9beb392f93ebf1f23e4ebf4d23fbe12b70063628d318012b71246d14f26b SHA512 460120fa2c76ad99f818f4183c4ded92eaa7f01a9dd782af1e93faf11caf2479053f45a9e9f0a602bf31631dba8be2d2c18bba28340c578126e8658ad4937c19
+DIST xapian-omega-1.4.23.tar.xz 571596 BLAKE2B fee64cf73a7bc8e6951c3555f1139bec8c94102b00ccf3a0a69c5037002f122f0d1688a798967f997f85d6c21bd69d72758168408d95159a7442bc46050fe915 SHA512 2137972cebb10315f35024c8a5e179ce082eab777e4fd795ba6700eeab0d77ec49b6e06d104222e77824898c25c1717d346564d59e5f349360fec89476e3ee4f
EBUILD xapian-omega-1.4.22.ebuild 1164 BLAKE2B 351e0e1101338af3cb572e1780e3b9f9db87185b7394052eb6c8e0ab3253360de63e2f221640042ba514232ab4fa6fce14941f9fc9d32becbf1ad9e799516aa1 SHA512 3855689749b297f1d517b1e3cab40f6d33200c364c1fdbdf7cd33d2f30696faa7301f98f74359422586a7644669e772e4967d9730d759f7385e1072b92de5bf0
+EBUILD xapian-omega-1.4.23.ebuild 1170 BLAKE2B d0c6ebc4aba16496356c4a99577004940257b60285def0d87c55a601080a3780efd9ab09c85c0ce587324f66527bbd88909381814d775cd3afb0eb9dc669e817 SHA512 25ccf46c937820321eac3a8153fec8da9baac934663c1afe0b8a345aef3f9da95973fa8509a0e60b0fc11a5db442d9c10e37b9ca8f56e51e3c84e20680aa999a
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-text/xapian-omega/xapian-omega-1.4.23.ebuild b/app-text/xapian-omega/xapian-omega-1.4.23.ebuild
new file mode 100644
index 000000000000..a9a75d694991
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.23.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+HOMEPAGE="https://xapian.org/"
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}