summaryrefslogtreecommitdiff
path: root/app-text/xapers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-text/xapers
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-text/xapers')
-rw-r--r--app-text/xapers/Manifest3
-rw-r--r--app-text/xapers/metadata.xml3
-rw-r--r--app-text/xapers/xapers-0.8.2-r1.ebuild34
3 files changed, 36 insertions, 4 deletions
diff --git a/app-text/xapers/Manifest b/app-text/xapers/Manifest
index 6595defbca3b..2f81c2f80b66 100644
--- a/app-text/xapers/Manifest
+++ b/app-text/xapers/Manifest
@@ -1,3 +1,4 @@
DIST xapers-0.8.2.tar.gz 160938 BLAKE2B cb21d04146f0cca39f1a706641e4cd2a83a796cbf4eb096379367203d91811c20798638a27215e9fdd9ffb32de908a389b0af57200f19bf4d2c8477a9c82ca93 SHA512 cdf1d4791dd48f579f9ee019492c26d10c9855c1ceef2c15bdc81dfdab0f1d74f54db453bb60a9d297a155a55d73cd26ff192875b4ee2b80d8f9f5d35a4bbcc9
+EBUILD xapers-0.8.2-r1.ebuild 753 BLAKE2B 56018b0006954269ce43a991bb2c80a0fcb8bdba21437bc36b522b33209c565b961539830eb038b7858bc73cc041d1b4d1c0e2ee7f6dd43b5817bb5474e0ab7e SHA512 52a5b97d1f454e8ddd90a2b5342f91e09dbce32aa63a4ad31211c4638615def445bc0ac317fc67d6c650270e8c4f0e55e6aa14e557e15b0c296e6e8e390da3ed
EBUILD xapers-0.8.2.ebuild 665 BLAKE2B 74ded3c69b277243be799924fe3abd57f517dbb2075f01c67ab955f88cfdd4c050c8fb9d5df415c60917d24973c6d9f567ede69038a0f13f74b6fc34d2cd5330 SHA512 f9d2eb51bd7a2c33c1ff1e44a1f2b3c04a205856c2adefaa03096e1fc4652ca4d282e2b112fb5bb414f657faa7489054a3c53258ca6ba96f2652f2bdfc3dbc67
-MISC metadata.xml 687 BLAKE2B b94d3d3f42be513d61d5e594ed9fbf13e83f3141d4dab74c48f396b411994c512a6aeb401e884b4891e17ac45f0329f52672dd3513420084e524a2548337bd26 SHA512 15bc8e58aec03907425c6d2ed011223b1e0b5925329e137f4f4ce0ff92b3ead2b22a3988a417164d51546c01c36172969bb6cd50fbd36a21f6dd99db1b89a944
+MISC metadata.xml 553 BLAKE2B 94c65255d3a407dd26f92c44f904dbf5e3d5a969a0e93203c11d68c92766060bdfd62615513cff9f1bd74ba7e124b066b6eec2a8fc434c564ec7c5486ecb728c SHA512 41a492b7a1c2e33d2ea0c44bdd480027e7e578139faf00da7f1e0226b3011d03963dcd7b221e5d065c762797a24f8c04c8a34c16dbe92c70ee7aa30764423758
diff --git a/app-text/xapers/metadata.xml b/app-text/xapers/metadata.xml
index b2b0bbc66d70..5b6ab9a1eabd 100644
--- a/app-text/xapers/metadata.xml
+++ b/app-text/xapers/metadata.xml
@@ -9,9 +9,6 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy maintainers</name>
</maintainer>
- <longdescription>
- Xapers is a personal document indexing system, geared towards academic journal articles.
- </longdescription>
<upstream>
<maintainer status="active">
<name>Jameson Graef Rollins</name>
diff --git a/app-text/xapers/xapers-0.8.2-r1.ebuild b/app-text/xapers/xapers-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..808db0ee8572
--- /dev/null
+++ b/app-text/xapers/xapers-0.8.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2016-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Personal document indexing system"
+HOMEPAGE="https://finestructure.net/xapers/"
+SRC_URI="https://finestructure.net/xapers/releases/${P}.tar.gz"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-text/poppler[utils]
+ dev-libs/xapian-bindings[python,${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xdg-utils"
+
+BDEPEND="test? ( ${RDEPEND} )"
+
+src_test() {
+ cd test || die
+ ./all || die
+}