summaryrefslogtreecommitdiff
path: root/app-text/wv2/wv2-0.4.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/wv2/wv2-0.4.2-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/wv2/wv2-0.4.2-r2.ebuild')
-rw-r--r--app-text/wv2/wv2-0.4.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/wv2/wv2-0.4.2-r2.ebuild b/app-text/wv2/wv2-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..5f5d76cee7ef
--- /dev/null
+++ b/app-text/wv2/wv2-0.4.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
+HOMEPAGE="http://wvware.sourceforge.net"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="zlib"
+
+RDEPEND="
+ dev-libs/glib
+ >=gnome-extra/libgsf-1.8:=
+ virtual/libiconv
+ zlib? ( sys-libs/zlib )"
+DEPEND="
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
+)
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
+
+src_configure() {
+ # due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWITH_ZLIB=$(usex zlib)
+ )
+ cmake-utils_src_configure
+}