summaryrefslogtreecommitdiff
path: root/app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild')
-rw-r--r--app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild b/app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild
new file mode 100644
index 000000000000..6afe4808c6af
--- /dev/null
+++ b/app-text/wiki2beamer/wiki2beamer-0.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool to produce LaTeX Beamer code from wiki-like input"
+
+MY_P=wiki2beamer-v${PV}
+HOMEPAGE="https://wiki2beamer.github.io/"
+SRC_URI="https://github.com/wiki2beamer/wiki2beamer/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-ruby/asciidoctor )"
+
+S="${WORKDIR}/wiki2beamer-${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-doc-examples-makefile.patch
+ "${FILESDIR}"/${P}-doc-man-makefile.patch
+)
+
+src_compile() {
+ use doc && emake -C doc/man/ wiki2beamer.1
+}
+
+src_install() {
+ use examples && dodoc -r doc/examples
+
+ use doc && doman doc/man/${PN}.1
+ dodoc ChangeLog README.md
+
+ python_doscript code/${PN}
+}