summaryrefslogtreecommitdiff
path: root/app-text/wiki2beamer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /app-text/wiki2beamer/files
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'app-text/wiki2beamer/files')
-rw-r--r--app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-examples-makefile.patch25
-rw-r--r--app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-man-makefile.patch58
2 files changed, 83 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-examples-makefile.patch b/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-examples-makefile.patch
new file mode 100644
index 000000000000..b444a0382e99
--- /dev/null
+++ b/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-examples-makefile.patch
@@ -0,0 +1,25 @@
+From 9b54418338adec929cdbdbd1b35e542fb6587fa4 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 7 Jul 2019 22:55:53 +0200
+Subject: doc/examples/Makefile: Use system-wide wiki2beamer
+
+---
+ doc/examples/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/examples/Makefile b/doc/examples/Makefile
+index e99253b..aeeb11e 100644
+--- a/doc/examples/Makefile
++++ b/doc/examples/Makefile
+@@ -9,7 +9,7 @@ all: $(patsubst %.wiki, %.pdf, $(WIKIFILES))
+
+ %.tex: %.wiki
+ @echo "Translating $<"
+- @python ../../code/wiki2beamer $< > $@
++ @wiki2beamer $< > $@
+
+
+ %.pdf: %.tex
+--
+2.21.0
+
diff --git a/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-man-makefile.patch b/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-man-makefile.patch
new file mode 100644
index 000000000000..42a406c791b5
--- /dev/null
+++ b/app-text/wiki2beamer/files/wiki2beamer-0.10.0-doc-man-makefile.patch
@@ -0,0 +1,58 @@
+From a78d36408bd88834fb2929423ee9f626c1dee428 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 7 Jul 2019 22:52:04 +0200
+Subject: doc/man/Makefile: Miscellaneous fixes
+
+- Fix dependencies
+- Add .PHONY markers
+- No longer call man(1) on "make html"
+- Make "make clean" robust to errors
+---
+ doc/man/Makefile | 28 ++++++++++++++++++----------
+ 1 file changed, 18 insertions(+), 10 deletions(-)
+
+diff --git a/doc/man/Makefile b/doc/man/Makefile
+index 8b3edc5..d545ef7 100644
+--- a/doc/man/Makefile
++++ b/doc/man/Makefile
+@@ -1,19 +1,27 @@
++.PHONY: all
+ all: man html
+
+ man1:
+ mkdir man1
+
+-man: wiki2beamer.xml man1
+- @asciidoctor -b manpage -d manpage wiki2beamer.adoc
+- @bzip2 --keep --stdout wiki2beamer.1 > man1/wiki2beamer.1.bz2
+- @man -D -M '.' wiki2beamer
++wiki2beamer.1: wiki2beamer.adoc
++ asciidoctor -b manpage -d manpage wiki2beamer.adoc
+
+-html: wiki2beamer.xml wiki2beamer.1
++man1/wiki2beamer.1.bz2: wiki2beamer.1 | man1
++ bzip2 --keep --stdout wiki2beamer.1 > man1/wiki2beamer.1.bz2
++
++wiki2beamer.html: wiki2beamer.adoc
+ asciidoctor -b html5 -d manpage wiki2beamer.adoc
+
+-clean:
+- rm wiki2beamer.1
+- rm wiki2beamer.html
+- rm man1/wiki2beamer.1.bz2
+- rmdir man1/
++.PHONY: man
++man: man1/wiki2beamer.1.bz2
+
++.PHONY: html
++html: wiki2beamer.html
++
++.PHONY: clean
++clean:
++ rm -f wiki2beamer.1
++ rm -f wiki2beamer.html
++ rm -f man1/wiki2beamer.1.bz2
++ [ ! -d man1 ] || rmdir man1
+--
+2.21.0
+