summaryrefslogtreecommitdiff
path: root/app-text/wgetpaste/wgetpaste-2.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-text/wgetpaste/wgetpaste-2.32.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-text/wgetpaste/wgetpaste-2.32.ebuild')
-rw-r--r--app-text/wgetpaste/wgetpaste-2.32.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/wgetpaste/wgetpaste-2.32.ebuild b/app-text/wgetpaste/wgetpaste-2.32.ebuild
new file mode 100644
index 000000000000..d738ebaa2c55
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.32.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+
+SRC_URI="https://github.com/zlin/wgetpaste/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ssl"
+
+RDEPEND="net-misc/wget[ssl?]"
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}