summaryrefslogtreecommitdiff
path: root/app-text/wdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/wdiff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/wdiff')
-rw-r--r--app-text/wdiff/Manifest4
-rw-r--r--app-text/wdiff/metadata.xml11
-rw-r--r--app-text/wdiff/wdiff-1.2.2-r1.ebuild34
-rw-r--r--app-text/wdiff/wdiff-1.2.2.ebuild33
4 files changed, 82 insertions, 0 deletions
diff --git a/app-text/wdiff/Manifest b/app-text/wdiff/Manifest
new file mode 100644
index 000000000000..6ea27bf836aa
--- /dev/null
+++ b/app-text/wdiff/Manifest
@@ -0,0 +1,4 @@
+DIST wdiff-1.2.2.tar.gz 1478567 BLAKE2B 80de7ecdd8fef1a4c9e6e0830e1af52d5087abc235dbe2bcf7542c0f017c1a21036243162fa6f70e714f3544d74e9a1add70dc22e69f306a17ce9bdd49c5bc15 SHA512 9272c225f4f61612197fe151cf8c913107169ac9fcd6c9f8472a0f56d9124d78a060944cea1b51489ca34311220f23638d043d43c733a3252cdbb7cceb1085ed
+EBUILD wdiff-1.2.2-r1.ebuild 869 BLAKE2B 302d6f9d26eb12219fe1748d0f9a6501d6f3d8a0245c587f0eec8e4843930afca88dd82e29e4767b882e1fb5821f66bf876a11da39e2052581adf8062047bda7 SHA512 88f9319cd22c1da88b666389659dc5b4d22fa40ffbc672961276a58df13a925e5ffe6044b523682a34083dc1882543b01841e2a5feb9b806c3c64d105f9739f7
+EBUILD wdiff-1.2.2.ebuild 839 BLAKE2B 05f9a12ffccb81d5f5aa8a99f604975255b76c95324068a7cf5fbce3411213689bac7becc3f9c6d110a53b81ee65f966272435b4e7559f8a51e14f5d7fb17c71 SHA512 bd6430c5c7ee706d37adc6489ba72d9021b5887e2864f45edfd23cc051340586fac6f79daef740bae11c16ad9b9ce6a54d980a0738bd6cf1965d85248fa91dae
+MISC metadata.xml 377 BLAKE2B ddada9afaa9d6031b4493ad27870959d71c7ad7852399b36468f41c0c11dbd591e0809101927d82a4f80520562b1fb8b65d577086218cc922a7b0e03b761005a SHA512 675191d217533506137aa85c390cbcf2c9683157b451c862701b5ab59d3ca437266243af0cb458f7ee5150fadb444a7eda648091eaa8b4f7e211e0bd98d92c7a
diff --git a/app-text/wdiff/metadata.xml b/app-text/wdiff/metadata.xml
new file mode 100644
index 000000000000..640511937e2f
--- /dev/null
+++ b/app-text/wdiff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <use>
+ <flag name="experimental">Build experimental utilities (mdiff, unify, wdiff2)</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-text/wdiff/wdiff-1.2.2-r1.ebuild b/app-text/wdiff/wdiff-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..88b88f79755c
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="https://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="experimental test"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/less
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ test? ( app-misc/screen )"
+
+src_configure() {
+ econf \
+ $(use_enable experimental)
+}
+
+src_test() {
+ # The test suite hangs in the '3: use pager' test
+ # when an incompatible screenrc is found
+ touch tests/screenrc || die
+ export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+ default
+}
diff --git a/app-text/wdiff/wdiff-1.2.2.ebuild b/app-text/wdiff/wdiff-1.2.2.ebuild
new file mode 100644
index 000000000000..f423a37982c4
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="https://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="experimental test"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/less
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ test? ( app-misc/screen )"
+
+src_configure() {
+ econf \
+ $(use_enable experimental)
+}
+
+src_test() {
+ # The test suite hangs in the '3: use pager' test
+ # when an incompatible screenrc is found
+ touch tests/screenrc || die
+ export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+ default
+}