summaryrefslogtreecommitdiff
path: root/app-text/wdiff/wdiff-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/wdiff/wdiff-1.2.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/wdiff/wdiff-1.2.2.ebuild')
-rw-r--r--app-text/wdiff/wdiff-1.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/wdiff/wdiff-1.2.2.ebuild b/app-text/wdiff/wdiff-1.2.2.ebuild
new file mode 100644
index 000000000000..f423a37982c4
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="https://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="experimental test"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/less
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ test? ( app-misc/screen )"
+
+src_configure() {
+ econf \
+ $(use_enable experimental)
+}
+
+src_test() {
+ # The test suite hangs in the '3: use pager' test
+ # when an incompatible screenrc is found
+ touch tests/screenrc || die
+ export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+ default
+}