summaryrefslogtreecommitdiff
path: root/app-text/vgrep/vgrep-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
commit68a32bc9fda17e8a546c0bba9d113c4c4659f6bb (patch)
treee043bb32648a3c75289450c0f4252aaabc1d4593 /app-text/vgrep/vgrep-2.7.0.ebuild
parent74a32c3ccafc7895a037d2b0cf73fc726286ec2e (diff)
gentoo auto-resync : 06:04:2024 - 18:30:38
Diffstat (limited to 'app-text/vgrep/vgrep-2.7.0.ebuild')
-rw-r--r--app-text/vgrep/vgrep-2.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/vgrep/vgrep-2.7.0.ebuild b/app-text/vgrep/vgrep-2.7.0.ebuild
new file mode 100644
index 000000000000..eac568a4d663
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests just run golangci-lint
+RESTRICT="test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ sed -e '/-ldflags/s/-s //' -i Makefile || die # bug 795345
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}