summaryrefslogtreecommitdiff
path: root/app-text/unpaper/unpaper-7.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
commit34ce8f465101950c92cb66c657d3244b5a8397db (patch)
tree5df8a8c3a293be4942f5df9f9cd81babb70fac96 /app-text/unpaper/unpaper-7.0.0.ebuild
parent24162508832f37f873ab12dfdfb191cf99318055 (diff)
gentoo auto-resync : 26:07:2022 - 08:58:19
Diffstat (limited to 'app-text/unpaper/unpaper-7.0.0.ebuild')
-rw-r--r--app-text/unpaper/unpaper-7.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/unpaper/unpaper-7.0.0.ebuild b/app-text/unpaper/unpaper-7.0.0.ebuild
new file mode 100644
index 000000000000..a26b83763386
--- /dev/null
+++ b/app-text/unpaper/unpaper-7.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=media-video/ffmpeg-2:0=[encode]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ dev-python/sphinx
+ test? ( dev-python/pytest )
+"