summaryrefslogtreecommitdiff
path: root/app-text/unac/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/unac/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/unac/files')
-rw-r--r--app-text/unac/files/unac-1.8.0-automake-1.13.1.patch40
-rw-r--r--app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch47
2 files changed, 87 insertions, 0 deletions
diff --git a/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch b/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch
new file mode 100644
index 000000000000..eaad52a53f14
--- /dev/null
+++ b/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch
@@ -0,0 +1,40 @@
+From 43e4c8788491c378862654933cc6d59d46f571c6 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 22 Jul 2013 23:07:04 -0400
+Subject: [PATCH] build: modernize for automake-1.14
+
+https://bugs.gentoo.org/show_bug.cgi?id=467618
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b4c658c..b40192e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,7 @@
+ # Documentation
+ #
+ man_MANS = unaccent.1 unac.3
+-INCLUDES = -DUNAC_VERSION=\"$(VERSION)\"
++AM_CPPFLAGS = -DUNAC_VERSION=\"$(VERSION)\"
+
+ #
+ # Support programs
+diff --git a/configure.ac b/configure.ac
+index 4a4eab6..444a9d5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,7 @@ AC_SUBST(MICRO_VERSION)
+ AM_INIT_AUTOMAKE([unac], $VERSION, nosubst)
+ AC_PREREQ(2.50)
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
+
+ AC_PROG_MAKE_SET
+
+--
+1.8.3.2
+
diff --git a/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch b/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch
new file mode 100644
index 000000000000..ca1d50274da6
--- /dev/null
+++ b/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch
@@ -0,0 +1,47 @@
+See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556379
+
+diff -r fd7eb0d70970 unac-1.8.0/unac.c
+--- a/unac-1.8.0/unac.c Fri Sep 17 10:35:14 2010 +0200
++++ b/unac-1.8.0/unac.c Fri Sep 17 10:36:07 2010 +0200
+@@ -13873,9 +13873,9 @@
+ *out_lengthp = 0;
+ } else {
+ char* utf16 = 0;
+- int utf16_length = 0;
++ size_t utf16_length = 0;
+ char* utf16_unaccented = 0;
+- int utf16_unaccented_length = 0;
++ size_t utf16_unaccented_length = 0;
+
+ if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
+ return -1;
+diff -r fd7eb0d70970 unac-1.8.0/unaccent.c
+--- a/unac-1.8.0/unaccent.c Fri Sep 17 10:35:14 2010 +0200
++++ b/unac-1.8.0/unaccent.c Fri Sep 17 10:40:34 2010 +0200
+@@ -90,7 +90,7 @@
+ const char* charset = argv[optind++];
+
+ char* unaccented = 0;
+- int unaccented_length = 0;
++ size_t unaccented_length = 0;
+
+ if(optind >= argc) {
+ #define BUFFER_SIZE 10240
+@@ -101,7 +101,7 @@
+ perror("");
+ exit(1);
+ }
+- printf("%.*s", unaccented_length, unaccented);
++ printf("%.*s", (int)unaccented_length, unaccented);
+ }
+ } else {
+ const char* string = argv[optind++];
+@@ -114,7 +114,7 @@
+
+ if(debug_level > UNAC_DEBUG_NONE)
+ fprintf(stderr, "unaccented version is ");
+- printf("%.*s\n", unaccented_length, unaccented);
++ printf("%.*s\n", (int)unaccented_length, unaccented);
+
+ if(optind < argc) {
+ const char* expected = argv[optind++];