summaryrefslogtreecommitdiff
path: root/app-text/u2ps/u2ps-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/u2ps/u2ps-0.8.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/u2ps/u2ps-0.8.4.ebuild')
-rw-r--r--app-text/u2ps/u2ps-0.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/u2ps/u2ps-0.8.4.ebuild b/app-text/u2ps/u2ps-0.8.4.ebuild
new file mode 100644
index 000000000000..9ba7a301cae0
--- /dev/null
+++ b/app-text/u2ps/u2ps-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="https://sourceforge.net/projects/u2ps.berlios/"
+SRC_URI="mirror://sourceforge/project/${PN}.berlios/${PN}-full-${PV}.tar.gz"
+
+LICENSE="GPL-3 GPL-3-with-font-exception free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/perl-5.6
+ dev-perl/Text-CharWidth
+ app-text/ghostscript-gpl
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-full-${PV}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --with-perl=/usr/bin/perl \
+ --with-gs=/usr/bin/gs \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake
+ emake man
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README DESIGN
+ doman man/u2ps.1
+}