summaryrefslogtreecommitdiff
path: root/app-text/txt2tags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/txt2tags
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/txt2tags')
-rw-r--r--app-text/txt2tags/Manifest4
-rw-r--r--app-text/txt2tags/files/51txt2tags-gentoo.el6
-rw-r--r--app-text/txt2tags/metadata.xml11
-rw-r--r--app-text/txt2tags/txt2tags-2.6-r1.ebuild80
4 files changed, 101 insertions, 0 deletions
diff --git a/app-text/txt2tags/Manifest b/app-text/txt2tags/Manifest
new file mode 100644
index 000000000000..22dd79de3f09
--- /dev/null
+++ b/app-text/txt2tags/Manifest
@@ -0,0 +1,4 @@
+AUX 51txt2tags-gentoo.el 214 BLAKE2B f5c5aad466fbc7eaf1ec36dcd4a52a914f1710f10fdce35640391ea4d9599903574967c1a7ab63c66f84ade4443f256d1bc197ec8179a6c3af75f1ec79cdd404 SHA512 e2a76d355c2fb163fc5c9b8013e04240206c8301fe2351fbdbc53d711625121e22cdeb2336488e6bffc355258a6d5dacbd48a2cec2d618dc4db17eebf0496feb
+DIST txt2tags-2.6.tgz 544724 BLAKE2B 9c8c37c6e003c7252276b32bacd373fe9143fdd93fdbc2bf0c23a83e2123c2a9636be5f106d248f2f0ecccd71eb9bc68cf8343557f10a7e6f8deacd8ade975ee SHA512 716e975f45dd304b6fd7d4e5aa8bd12e57c54120d892ae9abe11f1f3b5aeb747d8df0a9ffd34b8b5e6c8d422aac8830477f9a332c9e94040e1aa9946ebfe051e
+EBUILD txt2tags-2.6-r1.ebuild 1674 BLAKE2B 1fd20e256fe9de78c6b5c22e4a29687f7d22d80d25fa528a8f8bd75963144ccf82cf17ecc297e9e56b4f1053ba05b0ca3b6e4c56275694e3e9036a501e7abcea SHA512 a7d13cc9c8ea534b6c1b805051cfa937a379c9f916207be3dad7d86e508afbccf881cf2e5f464652e86d73d59aae3f1150b73fa7f9531c34f6912b3d5694fd69
+MISC metadata.xml 335 BLAKE2B 1852f3f02279c2d959ef2b886fa75f51c98771cf190057de977b730aae4c23941efa4b409b15ff3b859892484bcc559d8467e2b53a815b346b1165ac8af8621c SHA512 257cc7e9d2137e94fdc9d133133ca92b688ac2475a59dd30e1e0b4d548ce399cbf73cbe986f0f816c4be1f84668104e4e90f1257914512987aebb06697282b87
diff --git a/app-text/txt2tags/files/51txt2tags-gentoo.el b/app-text/txt2tags/files/51txt2tags-gentoo.el
new file mode 100644
index 000000000000..0b98bd66b8b2
--- /dev/null
+++ b/app-text/txt2tags/files/51txt2tags-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; txt2tags site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 't2t-mode "txt2tags-mode" "Major mode for editing Txt2Tags files" t)
+(add-to-list 'auto-mode-alist '("\\.t2t\\'" . t2t-mode))
diff --git a/app-text/txt2tags/metadata.xml b/app-text/txt2tags/metadata.xml
new file mode 100644
index 000000000000..f96fe67ab4db
--- /dev/null
+++ b/app-text/txt2tags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">txt2tags</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/txt2tags/txt2tags-2.6-r1.ebuild b/app-text/txt2tags/txt2tags-2.6-r1.ebuild
new file mode 100644
index 000000000000..701f24a7853a
--- /dev/null
+++ b/app-text/txt2tags/txt2tags-2.6-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit eutils elisp-common python-single-r1
+
+DESCRIPTION="Generate marked up documents (HTML, etc.)from a plain text file with markup"
+HOMEPAGE="https://txt2tags.org"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="emacs tk vim-syntax"
+
+DEPEND="${PYTHON_DEPS}
+ tk? ( dev-lang/tk )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ if use emacs; then
+ elisp-compile extras/txt2tags-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ dobin txt2tags
+
+ dodoc README ChangeLog*
+ dodoc doc/*.{pdf,t2t}
+ dodoc -r samples extras
+ newman doc/manpage.man txt2tags.1
+
+ # make .po files
+ for pofile in "${S}"/po/*.po; do
+ msgfmt -o ${pofile%%.po}.mo ${pofile}
+ done
+ domo po/*.mo
+
+ # emacs support
+ if use emacs; then
+ elisp-install ${PN} extras/txt2tags-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins extras/txt2tags.vim || die
+
+ echo 'au BufNewFile,BufRead *.t2t set ft=txt2tags' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim" || die
+ fi
+
+ python_fix_shebang "${D}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}