summaryrefslogtreecommitdiff
path: root/app-text/txt2tags/txt2tags-2.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-text/txt2tags/txt2tags-2.6-r1.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/txt2tags/txt2tags-2.6-r1.ebuild')
-rw-r--r--app-text/txt2tags/txt2tags-2.6-r1.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-text/txt2tags/txt2tags-2.6-r1.ebuild b/app-text/txt2tags/txt2tags-2.6-r1.ebuild
deleted file mode 100644
index 701f24a7853a..000000000000
--- a/app-text/txt2tags/txt2tags-2.6-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk?"
-
-inherit eutils elisp-common python-single-r1
-
-DESCRIPTION="Generate marked up documents (HTML, etc.)from a plain text file with markup"
-HOMEPAGE="https://txt2tags.org"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="emacs tk vim-syntax"
-
-DEPEND="${PYTHON_DEPS}
- tk? ( dev-lang/tk )
- vim-syntax? (
- || (
- app-editors/vim
- app-editors/gvim
- )
- )
- emacs? ( virtual/emacs )"
-
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-SITEFILE="51${PN}-gentoo.el"
-
-src_compile() {
- if use emacs; then
- elisp-compile extras/txt2tags-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- dobin txt2tags
-
- dodoc README ChangeLog*
- dodoc doc/*.{pdf,t2t}
- dodoc -r samples extras
- newman doc/manpage.man txt2tags.1
-
- # make .po files
- for pofile in "${S}"/po/*.po; do
- msgfmt -o ${pofile%%.po}.mo ${pofile}
- done
- domo po/*.mo
-
- # emacs support
- if use emacs; then
- elisp-install ${PN} extras/txt2tags-mode.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax/
- doins extras/txt2tags.vim || die
-
- echo 'au BufNewFile,BufRead *.t2t set ft=txt2tags' > "${T}/${PN}.vim"
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${T}/${PN}.vim" || die
- fi
-
- python_fix_shebang "${D}"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}