summaryrefslogtreecommitdiff
path: root/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild')
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
new file mode 100644
index 000000000000..853fc3b700e1
--- /dev/null
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyodystopia/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-db/tokyocabinet"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/fix_rpath.patch"
+ "${FILESDIR}/fix_ldconfig.patch"
+ "${FILESDIR}/remove_docinst.patch"
+)
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/libexec/${PN}
+}
+
+src_install() {
+ HTML_DOCS=( doc/. )
+
+ default
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/.
+ fi
+}
+
+src_test() {
+ emake -j1 check
+}