summaryrefslogtreecommitdiff
path: root/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild')
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
index 9a0508821fb2..853fc3b700e1 100644
--- a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils
+EAPI=7
DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
HOMEPAGE="http://fallabs.com/tokyodystopia/"
@@ -17,28 +15,27 @@ IUSE="examples"
DEPEND="dev-db/tokyocabinet"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
- epatch "${FILESDIR}/fix_ldconfig.patch"
- epatch "${FILESDIR}/remove_docinst.patch"
-}
+PATCHES=(
+ "${FILESDIR}/fix_rpath.patch"
+ "${FILESDIR}/fix_ldconfig.patch"
+ "${FILESDIR}/remove_docinst.patch"
+)
src_configure() {
- econf --libexecdir=/usr/libexec/${PN} || die
+ econf --libexecdir="${EPREFIX}"/usr/libexec/${PN}
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ HTML_DOCS=( doc/. )
- dohtml doc/* || die
+ default
if use examples; then
insinto /usr/share/${PF}/example
- doins example/* || die "Install failed"
+ doins example/.
fi
-
}
src_test() {
- emake -j1 check || die "Tests failed"
+ emake -j1 check
}