summaryrefslogtreecommitdiff
path: root/app-text/tidy-html5/tidy-html5-5.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/tidy-html5/tidy-html5-5.6.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/tidy-html5/tidy-html5-5.6.0.ebuild')
-rw-r--r--app-text/tidy-html5/tidy-html5-5.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/tidy-html5/tidy-html5-5.6.0.ebuild b/app-text/tidy-html5/tidy-html5-5.6.0.ebuild
new file mode 100644
index 000000000000..57460fad43e4
--- /dev/null
+++ b/app-text/tidy-html5/tidy-html5-5.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="http://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+
+RDEPEND="!app-text/htmltidy"
+
+DOCS=( README/{CODESTYLE,CONTRIBUTING,LICENSE,VERSION}.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake-utils_src_configure
+}