summaryrefslogtreecommitdiff
path: root/app-text/teckit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/teckit/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/teckit/files')
-rw-r--r--app-text/teckit/files/teckit-2.5.1-gcc43.patch12
-rw-r--r--app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch16
-rw-r--r--app-text/teckit/files/teckit-2.5.1-rc.patch15
3 files changed, 43 insertions, 0 deletions
diff --git a/app-text/teckit/files/teckit-2.5.1-gcc43.patch b/app-text/teckit/files/teckit-2.5.1-gcc43.patch
new file mode 100644
index 000000000000..f5a6bfddcfa2
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-gcc43.patch
@@ -0,0 +1,12 @@
+Index: TECkit_2_5_1/source/Compiler.cpp
+===================================================================
+--- TECkit_2_5_1.orig/source/Compiler.cpp
++++ TECkit_2_5_1/source/Compiler.cpp
+@@ -29,6 +29,7 @@ Description:
+
+ #include "Compiler.h"
+
++#include <cstdio>
+ #include <iostream>
+ #include <iomanip>
+ #include <algorithm>
diff --git a/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
new file mode 100644
index 000000000000..5a290f45133b
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
@@ -0,0 +1,16 @@
+No need to pass CFLAGS twice, esp. if they are used to feed g++
+Bug #338110
+
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -76,7 +76,7 @@ noexpat_CFLAGS="$CFLAGS"
+ noexpat_LIBS="$LIBS"
+ AC_CHECK_LIB(expat, XML_ExpatVersion)
+ AM_CONDITIONAL(SYSTEM_EXPAT, test x$ac_cv_lib_expat_XML_ExpatVersion = xyes)
+-expat_CFLAGS="$CFLAGS"
++expat_CFLAGS=""
+ expat_LIBS="$LIBS"
+ CFLAGS="$noexpat_CFLAGS"
+ LIBS="$noexpat_LIBS"
diff --git a/app-text/teckit/files/teckit-2.5.1-rc.patch b/app-text/teckit/files/teckit-2.5.1-rc.patch
new file mode 100644
index 000000000000..a4f1a3fae5d6
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-rc.patch
@@ -0,0 +1,15 @@
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -15,10 +15,6 @@ AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+
+-if test "${target_os}" = "mingw32"; then
+-AC_PROG_RC
+-fi
+-
+ AC_ARG_WITH(old-lib-names,
+ [ --with-old-lib-names Use old library names (for Windows only)],
+ [case "${withval}" in