summaryrefslogtreecommitdiff
path: root/app-text/spellutils/spellutils-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/spellutils/spellutils-0.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/spellutils/spellutils-0.7.ebuild')
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
new file mode 100644
index 000000000000..2f4a49cf772a
--- /dev/null
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
+HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
+SRC_URI="http://home.worldonline.dk/byrial/spellutils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa amd64"
+IUSE="nls"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ nls? ( virtual/libintl )
+"
+
+DOCS=( NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}