summaryrefslogtreecommitdiff
path: root/app-text/sgrep/sgrep-1.94a-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
commit78634f348a30a55cc55606ee1ecde032241ceaeb (patch)
tree528e39df571e37b31bfca1811c69bcc06c4af22f /app-text/sgrep/sgrep-1.94a-r2.ebuild
parent434fbe89e81a1fe06d92676be72ab7f862cc3f53 (diff)
gentoo auto-resync : 19:03:2023 - 06:33:49
Diffstat (limited to 'app-text/sgrep/sgrep-1.94a-r2.ebuild')
-rw-r--r--app-text/sgrep/sgrep-1.94a-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/sgrep/sgrep-1.94a-r2.ebuild b/app-text/sgrep/sgrep-1.94a-r2.ebuild
new file mode 100644
index 000000000000..de456e40df77
--- /dev/null
+++ b/app-text/sgrep/sgrep-1.94a-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Use structural criteria to grep and index text, SGML, XML and HTML and filter"
+HOMEPAGE="https://www.cs.helsinki.fi/u/jjaakkol/sgrep.html"
+SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "s:/usr/lib:${EPREFIX}/etc:g" sgrep.1 || die
+
+ # Clang 16, bug #900533
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/etc
+}
+
+src_install() {
+ dobin sgrep
+ doman sgrep.1
+ dodoc AUTHORS ChangeLog NEWS README sample.sgreprc
+
+ insinto /etc
+ newins sample.sgreprc sgreprc
+}