summaryrefslogtreecommitdiff
path: root/app-text/rpl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
commit47d5e233005d470dbd431a280e64ce6073fc7149 (patch)
tree135efe53d72c541429f68d7ed82186f2b34fcdb6 /app-text/rpl
parentbac9556f73da9ac333933778ce81c053bd989a26 (diff)
gentoo auto-resync : 09:04:2023 - 23:35:30
Diffstat (limited to 'app-text/rpl')
-rw-r--r--app-text/rpl/Manifest2
-rw-r--r--app-text/rpl/rpl-1.15.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/rpl/Manifest b/app-text/rpl/Manifest
index 02c9a42f8838..d2df4a12e8a7 100644
--- a/app-text/rpl/Manifest
+++ b/app-text/rpl/Manifest
@@ -1,3 +1,5 @@
+DIST rpl-1.15.2.gh.tar.gz 25452 BLAKE2B 95c826723683786411ff4ff5fe3a31ef4784fd682a735c369b758137aaf94b936aa4c714ed5db51c987710bb79dfeb46a8ec5837f97242d488ea4d92d980f202 SHA512 67418a89e3ab8770dce4945d3db5d7a54986ba4357a902249062d28d9abda5856c82e41092b703e138fe6d70e6ea3c5f5cd57eead83d0d39addda6c746e85d81
DIST rpl-1.9.1.gh.tar.gz 22858 BLAKE2B 583a29fd34d7a0d2b3a35b0966a6bd42ac2851750806a97846785dc0331bd5d2199ffba3309184e64a4aa7194f9ae4b9ecb2acc500830b841bd34e2184ec1798 SHA512 be480c6788fa1eb672b892d798deb7d263eae227dac5d93a55f28ebf3b4a43f896eb10edd00e52aad1cd57f4a80faf4a4552b4762b26da273cd05f0c5bce754a
+EBUILD rpl-1.15.2.ebuild 622 BLAKE2B a8becebc3d009a8a873ad59ef20a3d082f082838b172e656f8fb009d4d9784b5903d09b1ce915924a5240342af0c9776e110157a738b00c6b7168789eb824427 SHA512 d26a4248e21db4a55fe72c1937b34cb8459285483ead42f4b6bcdeff1fe4efabcd6ff1c3ede99d4b8b76d31626406a292ce05c9ffa648f50039fc223cf4d2f74
EBUILD rpl-1.9.1.ebuild 644 BLAKE2B 4e241dc1ce00e17b4b4f836bde5080ae74d910a7e83d7312cce286d7d94c89482dbbe78193ef08fb837c2f6b080d8187f30bdf2b430bcecbff038b386b16124a SHA512 ddd0d6571d911cabb071093654cdc3d000f607e436eb58d1c5d7e8044d0356b7133dd32fcd70f63bdf1faa02773421f403bf4191703b946a0ccbee28d2d206cf
MISC metadata.xml 415 BLAKE2B 7d6fcfc502df7caae990705cac7ad186ea3cb7ea5eafc85cd1a04fde93e09dbaa7001abc531a74092750f925c60a1c47de13687f4105585090b30654e79e7ef6 SHA512 61f24dace96be9d82a7f539195ec7d2b76cad2cc04dd1f51eef648277307975502d29ea7e6f479dc6a293dbc121d71d8097b40227103275d35d40e2026e68da6
diff --git a/app-text/rpl/rpl-1.15.2.ebuild b/app-text/rpl/rpl-1.15.2.ebuild
new file mode 100644
index 000000000000..902a5491d3c1
--- /dev/null
+++ b/app-text/rpl/rpl-1.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/
+ https://github.com/rrthomas/rpl"
+SRC_URI="
+ https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"