summaryrefslogtreecommitdiff
path: root/app-text/rpl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /app-text/rpl
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'app-text/rpl')
-rw-r--r--app-text/rpl/Manifest4
-rw-r--r--app-text/rpl/metadata.xml2
-rw-r--r--app-text/rpl/rpl-1.9.1.ebuild27
3 files changed, 32 insertions, 1 deletions
diff --git a/app-text/rpl/Manifest b/app-text/rpl/Manifest
index 0bf45be2a6b2..ac476cbf0c99 100644
--- a/app-text/rpl/Manifest
+++ b/app-text/rpl/Manifest
@@ -1,3 +1,5 @@
DIST rpl-1.6.7.tar.gz 21867 BLAKE2B ac523aa836312d6ed6db9eabaf9b6499ce00047ce1a4d35bf398f769036d65aa5b52c410b2110cf5bb14c31d782bc1c424bcd1b2a26692de28ca70fd452b18f1 SHA512 f853eae0ce0a82d864e72ecf3fd3f20fba10553357b23d0012ed22ee0efd57bbefea71095775f7215323d829057f6579aadfc006b6a893972e05039784dc5add
+DIST rpl-1.9.1.gh.tar.gz 22858 BLAKE2B 583a29fd34d7a0d2b3a35b0966a6bd42ac2851750806a97846785dc0331bd5d2199ffba3309184e64a4aa7194f9ae4b9ecb2acc500830b841bd34e2184ec1798 SHA512 be480c6788fa1eb672b892d798deb7d263eae227dac5d93a55f28ebf3b4a43f896eb10edd00e52aad1cd57f4a80faf4a4552b4762b26da273cd05f0c5bce754a
EBUILD rpl-1.6.7.ebuild 699 BLAKE2B 96252444486478f421942989476311710b3fa8925bfd734791984675d01b091aeac2a5216b390edfede919cfcbc6ec24854016a3355b674bca880bb1da8cd56f SHA512 0ed10c86134712b76464a8ef40faccde42dfecbb2e2098795ee7d6520b40509db300c00cfd196e8c84d1222110b3de5719fa8f06808d5bb94785833c9df9dfce
-MISC metadata.xml 338 BLAKE2B 64a9c58a45097871d3d71b78a46857234cb27a5db16cd80b1dc9e7d9f4dfe650f605d1e8f1ba8a645d50d67b4e2ba21b56308e06aaae3cd264920705e5c4a8c3 SHA512 e8231d1fb1b810948ec4ff31afceaaffa7b6d3f0ed565118f8555cb0721de20dad9a845e213162b3b1619e2b20610e4df0843293df049e17f8e4e1977957104a
+EBUILD rpl-1.9.1.ebuild 639 BLAKE2B 8d88f8f1c50215ace0a732a742d7a2569eb572782a7458190c37d02759d54769b7aee818afe56b76a9297015a4a3f0654c8c727219fcb3de874cb2ca6ee6aa04 SHA512 cc90855316ab3fe93a0dec1973084fcfffeb01bf58d54d299445406b01bee1a16fdf23bdf1d7ca6893fcd22881059ca36b6668126a397bc2721700a010049249
+MISC metadata.xml 414 BLAKE2B 775bb8e0223d3d328d1ef12e9343d25ba343ee4ab602350e3a13b62c9ec65be46f22861d8fb56cdd5022e8acc1b3444e755f3724195ac50a09d207484b8e4463 SHA512 15cb990515a832bbf5fb925742a830f011e49d839e24eba606f260351fd6014d9038698f099cd7cba4a5e5e39d5ca0fd9ea516953c21f33aff778c128e893430
diff --git a/app-text/rpl/metadata.xml b/app-text/rpl/metadata.xml
index 4962fc76aac4..7f9ce6a706e0 100644
--- a/app-text/rpl/metadata.xml
+++ b/app-text/rpl/metadata.xml
@@ -5,7 +5,9 @@
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="sourceforge">rpl</remote-id>
+ <remote-id type="github">rrthomas/rpl</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-text/rpl/rpl-1.9.1.ebuild b/app-text/rpl/rpl-1.9.1.ebuild
new file mode 100644
index 000000000000..039620d83337
--- /dev/null
+++ b/app-text/rpl/rpl-1.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/ https://github.com/rrthomas/rpl"
+SRC_URI="https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"
+
+python_compile_all() {
+ # Compile man file
+ emake rpl.1
+}