summaryrefslogtreecommitdiff
path: root/app-text/rpl/rpl-1.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
commit47d5e233005d470dbd431a280e64ce6073fc7149 (patch)
tree135efe53d72c541429f68d7ed82186f2b34fcdb6 /app-text/rpl/rpl-1.15.2.ebuild
parentbac9556f73da9ac333933778ce81c053bd989a26 (diff)
gentoo auto-resync : 09:04:2023 - 23:35:30
Diffstat (limited to 'app-text/rpl/rpl-1.15.2.ebuild')
-rw-r--r--app-text/rpl/rpl-1.15.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/rpl/rpl-1.15.2.ebuild b/app-text/rpl/rpl-1.15.2.ebuild
new file mode 100644
index 000000000000..902a5491d3c1
--- /dev/null
+++ b/app-text/rpl/rpl-1.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/
+ https://github.com/rrthomas/rpl"
+SRC_URI="
+ https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"