summaryrefslogtreecommitdiff
path: root/app-text/robodoc/robodoc-4.99.43-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-text/robodoc/robodoc-4.99.43-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-text/robodoc/robodoc-4.99.43-r1.ebuild')
-rw-r--r--app-text/robodoc/robodoc-4.99.43-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/robodoc/robodoc-4.99.43-r1.ebuild b/app-text/robodoc/robodoc-4.99.43-r1.ebuild
new file mode 100644
index 000000000000..df1ddb680824
--- /dev/null
+++ b/app-text/robodoc/robodoc-4.99.43-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Automating Software Documentation"
+HOMEPAGE="https://www.xs4all.nl/~rfsber/Robo/robodoc.html"
+SRC_URI="https://rfsber.home.xs4all.nl/Robo/archives/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}/${P}_clean_libc.patch"
+)
+
+RDEPEND=">=dev-util/ctags-5.3.1"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins Contributions/*
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r Examples/PerlExample
+ fi
+}