summaryrefslogtreecommitdiff
path: root/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/rfcutil/rfcutil-3.2.3-r2.ebuild')
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
new file mode 100644
index 000000000000..2706c02ec2ab
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils prefix
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="return all related RFCs based upon a number or a search string"
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ || ( www-client/lynx virtual/w3m )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${MY_P}-paths.patch \
+ "${FILESDIR}"/${MY_P}-index.patch
+ eprefixify ${MY_P}
+}
+
+src_install() {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG KNOWN_BUGS README
+ keepdir /var/cache/rfc
+}
+
+pkg_postinst() {
+ elog "Gaarde suggests you make a cron.monthly to run the following:"
+ elog " ${EPREFIX}/usr/bin/rfc -i"
+}
+
+pkg_prerm() {
+ rm -f "${EROOT}"/var/cache/rfc/*
+}