summaryrefslogtreecommitdiff
path: root/app-text/recode/recode-3.7.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
commit5d0c50eb490582cf1277e150ee5bb63a90b85aa6 (patch)
tree7204c80f526d36b5a4c7c6cd1339971b97636808 /app-text/recode/recode-3.7.12.ebuild
parent13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (diff)
gentoo auto-resync : 22:11:2022 - 13:06:24
Diffstat (limited to 'app-text/recode/recode-3.7.12.ebuild')
-rw-r--r--app-text/recode/recode-3.7.12.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/app-text/recode/recode-3.7.12.ebuild b/app-text/recode/recode-3.7.12.ebuild
deleted file mode 100644
index 73dc2c7e5900..000000000000
--- a/app-text/recode/recode-3.7.12.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Convert files between various character sets"
-HOMEPAGE="https://github.com/rrthomas/recode"
-SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-# librecode soname version
-SLOT="0/3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="nls test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="virtual/libiconv"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- python_has_version "dev-python/cython[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- tc-export CC LD
-
- # on solaris -lintl is needed to compile
- [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
-
- # -fanalyzer substantially slows down the build and isn't useful for
- # us. It's useful for upstream as it's static analysis, but it's not
- # useful when just getting something built.
- export gl_cv_warn_c__fanalyzer=no
-
- econf \
- $(use_enable nls) \
- --disable-static
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}