summaryrefslogtreecommitdiff
path: root/app-text/pytextile/pytextile-2.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/pytextile/pytextile-2.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/pytextile/pytextile-2.3.3.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.3.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-2.3.3.ebuild b/app-text/pytextile/pytextile-2.3.3.ebuild
new file mode 100644
index 000000000000..3a17b6c192d4
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_PN="python-textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # This resolves a nasty race condition, courtesy of Arfrever
+ sed -e 's:with-id = 1::' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Testsuite failed under ${EPYTHON}"
+}