summaryrefslogtreecommitdiff
path: root/app-text/pytextile/pytextile-2.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/pytextile/pytextile-2.3.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/pytextile/pytextile-2.3.3.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.3.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-2.3.3.ebuild b/app-text/pytextile/pytextile-2.3.3.ebuild
new file mode 100644
index 000000000000..4641ee712126
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="python-textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # This resolves a nasty race condition, courtesy of Arfrever
+ sed -e 's:with-id = 1::' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Testsuite failed under ${EPYTHON}"
+}