summaryrefslogtreecommitdiff
path: root/app-text/pspresent/pspresent-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/pspresent/pspresent-1.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/pspresent/pspresent-1.3-r1.ebuild')
-rw-r--r--app-text/pspresent/pspresent-1.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/pspresent/pspresent-1.3-r1.ebuild b/app-text/pspresent/pspresent-1.3-r1.ebuild
new file mode 100644
index 000000000000..20931af5b1d4
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to display full-screen PostScript presentations"
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="xinerama"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ app-text/ghostscript-gpl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ if ! use xinerama ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile || die "sed Makefile"
+ fi
+ sed -i Makefile \
+ -e 's|= -Wall -O2|+= -Wall|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin pspresent
+ doman pspresent.1
+}