summaryrefslogtreecommitdiff
path: root/app-text/psmark/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-12 19:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-12 19:10:40 +0000
commit4fc30e4e13ecfbe29fbef3b5caf96218eab30b68 (patch)
tree76daccda237a1d7020464e1de2c699391c86cf92 /app-text/psmark/files
parent4c4e8e9bf6d1ef49be600d77fcbbd7be716aece7 (diff)
gentoo auto-resync : 12:01:2024 - 19:10:40
Diffstat (limited to 'app-text/psmark/files')
-rw-r--r--app-text/psmark/files/psmark-2.1-Makefile-QA.patch19
-rw-r--r--app-text/psmark/files/psmark-2.1-string.patch15
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/psmark/files/psmark-2.1-Makefile-QA.patch b/app-text/psmark/files/psmark-2.1-Makefile-QA.patch
new file mode 100644
index 000000000000..145fe3a32e8e
--- /dev/null
+++ b/app-text/psmark/files/psmark-2.1-Makefile-QA.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,14 +3,13 @@
+ all:
+ make clean
+ make psmark
+
+ psmark:
+- gcc $(CFLAGS) -o psmark psmark.c
+- strip psmark
++ $(CC) $(CFLAGS) $(LDFLAGS) -o psmark psmark.c
+
+ clean:
+ rm -f *.o psmark
+
+ install:
+- install -s psmark /usr/bin/
++ install psmark /usr/bin/
+ install psmark.1 /usr/man/man1/
diff --git a/app-text/psmark/files/psmark-2.1-string.patch b/app-text/psmark/files/psmark-2.1-string.patch
new file mode 100644
index 000000000000..1d1fb3dfbb57
--- /dev/null
+++ b/app-text/psmark/files/psmark-2.1-string.patch
@@ -0,0 +1,15 @@
+--- a/psmark.c
++++ b/psmark.c
+@@ -97,9 +97,9 @@
+ progname);
+ fprintf(stderr,"example:\n %s -i test.ps -o output.ps -b 0.4 -s 15 \"vertical label\""
+ "\n\n",progname);
+- fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but
+- they are not in sync with the page corner: some fiddling is required
+- to get text to appear right in the corner.\n"
++ fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but\n"
++ "they are not in sync with the page corner: some fiddling is required\n"
++ "to get text to appear right in the corner.\n"
+ );
+
+ exit(error ? EXIT_FAILURE : EXIT_SUCCESS);