summaryrefslogtreecommitdiff
path: root/app-text/pelican/pelican-4.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
commite4b9f141e31db1e069e3bcf5b1fb81af77b0cace (patch)
treed1879c44ce14e7b9450b0f9c711f653779584754 /app-text/pelican/pelican-4.8.0.ebuild
parentbd3c6f11646b7601637fa3245cf8a363e9fa0034 (diff)
gentoo auto-resync : 12:07:2022 - 13:33:15
Diffstat (limited to 'app-text/pelican/pelican-4.8.0.ebuild')
-rw-r--r--app-text/pelican/pelican-4.8.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-text/pelican/pelican-4.8.0.ebuild b/app-text/pelican/pelican-4.8.0.ebuild
new file mode 100644
index 000000000000..ea0e121101a7
--- /dev/null
+++ b/app-text/pelican/pelican-4.8.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc examples markdown"
+
+RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2020.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-10.1[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-1.1[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ >=dev-python/markdown-3.1[${PYTHON_USEDEP}]
+ dev-python/typogrify[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README.rst )
+
+EPYTEST_DESELECT=(
+ # Needs investigation, we weren't running tests at all before
+ pelican/tests/test_testsuite.py::TestSuiteTest::test_error_on_warning
+ pelican/tests/test_pelican.py::TestPelican::test_basic_generation_works
+ pelican/tests/test_pelican.py::TestPelican::test_custom_generation_works
+)
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ if use examples; then
+ docinto /usr/share/doc/${PF}
+ docompress -x /usr/share/doc/${PF}/samples
+ dodoc -r samples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Typographical enhancements (alternative to markdown)" dev-python/typogrify
+}