summaryrefslogtreecommitdiff
path: root/app-text/pdfsandwich/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-text/pdfsandwich/files
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-text/pdfsandwich/files')
-rw-r--r--app-text/pdfsandwich/files/pdfsandwich-0.1.7-gentoo.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/files/pdfsandwich-0.1.7-gentoo.patch b/app-text/pdfsandwich/files/pdfsandwich-0.1.7-gentoo.patch
new file mode 100644
index 000000000000..f16b94379b6a
--- /dev/null
+++ b/app-text/pdfsandwich/files/pdfsandwich-0.1.7-gentoo.patch
@@ -0,0 +1,43 @@
+--- a/Makefile 2020-05-21 20:46:14.961927486 +0200
++++ b/Makefile 2020-05-21 20:49:16.203121793 +0200
+@@ -6,7 +6,7 @@
+
+ SOURCE = pdfsandwich.ml
+ TARGET = pdfsandwich
+-MANUAL = $(TARGET).1.gz
++MANUAL = $(TARGET).1
+
+ VERSION := $(shell cat pdfsandwich_version)
+
+@@ -24,7 +24,7 @@
+
+ $(MANUAL): manual.txt
+ # you need gawk for this:
+- ./txt2man -t PDFSANDWICH manual.txt | gzip -9 > $(MANUAL)
++ ./txt2man -t PDFSANDWICH manual.txt > $(MANUAL)
+
+ # Canceling pathological implicit rule:
+ %: %.o
+@@ -40,7 +40,7 @@
+ include makefile.installprefix
+
+ PREF = $(DESTDIR)$(PREFIX)
+-INSTALL = install -s
++INSTALL = install
+ CP = cp
+ INSTALLBINDIR = $(PREF)/bin
+ INSTALLMANDIR = $(PREF)/share/man/man1
+@@ -47,12 +47,8 @@
+ INSTALLDOCDIR = $(PREF)/share/doc/$(TARGET)
+
+ install: $(DOCFILES) $(ADDITIONAL)
+- (umask 0022; mkdir -p $(INSTALLBINDIR) $(INSTALLDOCDIR) $(INSTALLMANDIR))
++ (umask 0022; mkdir -p $(INSTALLBINDIR))
+ $(INSTALL) $(TARGET) $(INSTALLBINDIR)
+- $(CP) $(DOCFILES) $(INSTALLDOCDIR)
+- gzip -9 $(INSTALLDOCDIR)/changelog
+- $(CP) $(MANUAL) $(INSTALLMANDIR)
+- chmod 644 $(INSTALLDOCDIR)/* $(INSTALLMANDIR)/*
+
+ uninstall:
+ rm -rf $(INSTALLBINDIR)/$(TARGET) $(INSTALLDOCDIR) $(INSTALLMANDIR)/$(MANUAL)