summaryrefslogtreecommitdiff
path: root/app-text/pdfgrep/pdfgrep-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/pdfgrep/pdfgrep-2.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/pdfgrep/pdfgrep-2.0.1.ebuild')
-rw-r--r--app-text/pdfgrep/pdfgrep-2.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/pdfgrep/pdfgrep-2.0.1.ebuild b/app-text/pdfgrep/pdfgrep-2.0.1.ebuild
new file mode 100644
index 000000000000..fb916b4566ae
--- /dev/null
+++ b/app-text/pdfgrep/pdfgrep-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A tool similar to grep which searches text in PDFs"
+HOMEPAGE="http://www.pdfgrep.org/"
+SRC_URI="http://www.pdfgrep.org/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pcre test unac"
+
+RDEPEND="
+ app-text/poppler:=[cxx]
+ dev-libs/libgcrypt:0=
+ pcre? ( dev-libs/libpcre[cxx] )
+ unac? ( app-text/unac )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-texlive/texlive-latex
+ dev-util/dejagnu
+ )"
+
+src_configure() {
+ econf \
+ $(use_with pcre libpcre) \
+ $(use_with unac)
+}