summaryrefslogtreecommitdiff
path: root/app-text/par/par-1.52-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/par/par-1.52-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/par/par-1.52-r1.ebuild')
-rw-r--r--app-text/par/par-1.52-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/par/par-1.52-r1.ebuild b/app-text/par/par-1.52-r1.ebuild
new file mode 100644
index 000000000000..7e6f9b7dcf6e
--- /dev/null
+++ b/app-text/par/par-1.52-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="Par${PV/./}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
+HOMEPAGE="http://www.nicemice.net/par/"
+SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="!dev-util/par
+ !app-arch/par"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS" \
+ LINK1="$(tc-getCC) $LDFLAGS" || die 'make failed'
+}
+
+src_install() {
+ newbin par par-format
+ doman par.1
+ dodoc releasenotes par.doc
+}