summaryrefslogtreecommitdiff
path: root/app-text/paperwork/paperwork-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-text/paperwork/paperwork-2.0.3.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-text/paperwork/paperwork-2.0.3.ebuild')
-rw-r--r--app-text/paperwork/paperwork-2.0.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/paperwork/paperwork-2.0.3.ebuild b/app-text/paperwork/paperwork-2.0.3.ebuild
new file mode 100644
index 000000000000..b9ec9918ccc6
--- /dev/null
+++ b/app-text/paperwork/paperwork-2.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="~app-text/openpaperwork-core-${PV}[${PYTHON_USEDEP}]
+ ~app-text/openpaperwork-gtk-${PV}[${PYTHON_USEDEP}]
+ ~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ x11-libs/libnotify[introspection]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-desktop_file.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH="src" "${EPYTHON}" src/paperwork_gtk/main.py install \
+ --icon_base_dir="${ED}"/usr/share/icons \
+ --data_base_dir="${ED}"/usr/share
+}