summaryrefslogtreecommitdiff
path: root/app-text/paperwork-backend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /app-text/paperwork-backend
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'app-text/paperwork-backend')
-rw-r--r--app-text/paperwork-backend/Manifest3
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild61
2 files changed, 64 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/Manifest b/app-text/paperwork-backend/Manifest
index 3dbaf1b3219e..ac32f0c047b9 100644
--- a/app-text/paperwork-backend/Manifest
+++ b/app-text/paperwork-backend/Manifest
@@ -1,3 +1,6 @@
+DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
DIST paperwork-backend-2.1.2.tar.gz 1346499 BLAKE2B daf8c6dee97b0bdf814bcf7e9c83a80ab878250994a770f5fa6be4c0b4e23f0def51e22c0a8652a19e9294f3fab0b522b25c2a91c306ad760d568faf76a78610 SHA512 0156baa658a9fe26680bf6d146af3f03b98da307ee1cfaf4803f8b70a2ffdb0010fe23c4d4f9b5a572919c4be94a1aad4fd070220849248cdb18c5b1c4bc478b
+DIST paperwork-data-2.2.1.tar.gz 5210355 BLAKE2B 48ee8f9828f7aed9b41c998c2cdc43a2b98c2a2482e388500b8d04867a450bbf3264ef5a87d7f215f1389943e4cbab452d3a7a6235d63cfdb27127ab56ad9c2f SHA512 cf663368f733f45dde8242c3ad9ba405361628bddb7e8aed9dffeb5bb86c1abac7a3485cb7e2042d65006f8f336390fa81ea182dad62f4259b79805ac7a0416b
EBUILD paperwork-backend-2.1.2.ebuild 1317 BLAKE2B 1cd4f19bdd2c9ebd2808ec4a98e9dcc367be5061ff439019894e722f13d39bd5eeed39a21bcfc34fee76d931fc59227cc53693b5a02a083eb55e4d562fc1621a SHA512 517e128b5eb38752eb173a308ec4f898d1a40de714c9349c8f0553bf416dd411b87fc6071fae196437a91ee6099db9cd0ef786d7efc3fe7289025f007df23c6b
+EBUILD paperwork-backend-2.2.1.ebuild 1621 BLAKE2B 8b56ff13a80f94821f8d13ecff3a3eab5936c3440b0f9eba67d8e57b372af0ea83ef24bfedc61a0668341f96bf8b455a7fab0b36af957fa3a07b742ab86d2798 SHA512 79c2b6dccfc55d25abb493e91badbb2c03612976cc2254ab9003552e792fc25924897b98c7b7363bd0b2925c4b47587f576cfe75b3355f9d041ee0ba52a918c7
MISC metadata.xml 410 BLAKE2B c6ed41347886699086f69694dbaa5134e9ebfb02cbc157909e02971cce01cc562e82f31c15bb5ae1ee261d79d6e5a9ece81c1cf7fa48a9839ddf467c06fab392 SHA512 01bf86e9c8fd1b9e1d514edca46992609eb8789fe95ea914914ef4fc43c7b3f0fcaffaa712bb5c72e3936679b44749837b0ba73c2b62c1b0bc52f318fcc8e31f
diff --git a/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild b/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild
new file mode 100644
index 000000000000..7a31ab09d094
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+# Update from release hash at:
+# https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/tags
+REL_HASH="0bea4054"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2
+ https://download.openpaper.work/data/paperwork/master_${REL_HASH}/data.tar.gz -> paperwork-data-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/openpaperwork-core[${PYTHON_USEDEP}]
+ app-text/openpaperwork-gtk[${PYTHON_USEDEP}]
+ app-text/poppler[introspection]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ test? (
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ )
+"
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+distutils_enable_tests unittest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ default
+ cp -a "${WORKDIR}"/${PN} ${WORKDIR}/paperwork-${PV}/
+}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}