summaryrefslogtreecommitdiff
path: root/app-text/paper-clip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-17 02:56:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-17 02:56:05 +0000
commite65f4866ce8216f52dc1316fba72f6962683ebfe (patch)
tree15688e5760d123993caedc3feb5873915b90b011 /app-text/paper-clip
parenta06c47011120ee885d0ea7adb1a080bb16f03b3c (diff)
gentoo auto-resync : 17:12:2023 - 02:56:05
Diffstat (limited to 'app-text/paper-clip')
-rw-r--r--app-text/paper-clip/Manifest2
-rw-r--r--app-text/paper-clip/paper-clip-3.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/paper-clip/Manifest b/app-text/paper-clip/Manifest
index 97f14e2963fa..cd6a45fc0a21 100644
--- a/app-text/paper-clip/Manifest
+++ b/app-text/paper-clip/Manifest
@@ -1,4 +1,6 @@
DIST paper-clip-3.2.tar.gz 196899 BLAKE2B d089185db9557431c22ed64b63155920c60795315fad1901b0a5ce5fd0230b7246d375a10a8ce150ad4fdce16f9062aa4770601b741189b877e57d4fe948d7a2 SHA512 6a08fe04f3431d7444ba67da34b60d56b7cf065199fceef7086ad3f181f18c703b8d011e6dbef39942011e7f92e3728f1f1a5164a575bab43b370fca9c4fdb98
+DIST paper-clip-3.6.tar.gz 171190 BLAKE2B a31673c9c3a1f889a63561a244d966195dac2738eb4070dfd01807c7406c7f8acb0277509c6924de37068aa904c3f1ee4f6de3882bf734470b67dd77b34afcf3 SHA512 4ebfa6789d31f85dc6b38119f7fb1f88ca06a32872ab1341d4a4fcd898eb3c672673a630d56f373294c053bdcee7573206a5fe89da45b76366f65e9bb441451a
EBUILD paper-clip-3.2-r1.ebuild 1381 BLAKE2B f9f2b45b1a403f0ac99ff5a1db2538fb555295d10c7032ca4d19a58974b8d15196200921d462b1fb9809d91d22cc604167cc413c79f6acc2bcfe94ef991bf081 SHA512 1ad39b7631c67b78516575b86519c1236b00cb07ede8e34d0d5f497e127e2a2790807109d182f68ecb137ff994eee8aacba51cf73c390701ddb7cc08c44f4960
+EBUILD paper-clip-3.6.ebuild 1405 BLAKE2B 15fe0fa666500be8c9d6e4ccb8a70c9c42f3c5898dfdd381da8529e24011cdba6b04d98d784daf8085301670f474f4e8dfea7aac2482972a0adcc3291a311012 SHA512 c647588de67f57b691cdfbca7bf1f6f8ade719fd89538888b4e8ace938feda422e5ae8251a62aee16ebd8ffe403fb319e704c43e9665014695fdeea3d81c1bee
EBUILD paper-clip-9999.ebuild 1382 BLAKE2B 12662c41f9864a9e64cc00a7e4b165c0bb1895a58f4a6973bff12223e85b7c053673dd545fd8b07c661ec834edaacb6b5f6f00ee9329d65016b28bdc7bbaff90 SHA512 fabb15a34e83d8b0aa264e8adc8fb2af294fd5631f666127e6a6eca8e7c1463762e096f9df8029f8fb620adbb972109909fbba64b5d4bcdb45b6666ccd27553c
MISC metadata.xml 413 BLAKE2B 66acd49c6583aec7c89aa17de477237b5214aefc73b4814eb8170f1af322fd3d1565557060e2fc63027740457c84131e9d6d4be0f1dd4d531ac7da79429e0c91 SHA512 69d713bd2b11742920a25f5db125de72bb44403a049a1969e988b124d2d88ea36d6ac04a8b2091380f9208ad4407f354322e307a433bb58c413353069eb8cccc
diff --git a/app-text/paper-clip/paper-clip-3.6.ebuild b/app-text/paper-clip/paper-clip-3.6.ebuild
new file mode 100644
index 000000000000..3d5055cd6861
--- /dev/null
+++ b/app-text/paper-clip/paper-clip-3.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="Paper-Clip"
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Edit the title, author, keywords and more details of PDF documents"
+HOMEPAGE="https://github.com/Diego-Ivan/Paper-Clip/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Diego-Ivan/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Diego-Ivan/${REAL_PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Only validations, the appdata one fails.
+
+RDEPEND="
+ app-text/poppler:=[cairo,introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/libportal:=[gtk,introspection,vala]
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1[introspection,vala]
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ # Symlink "pdf-metadata-editor" (old name?) to "${PN}"
+ dosym -r /usr/bin/pdf-metadata-editor "/usr/bin/${PN}"
+
+ mv "${ED}/usr/share/appdata" "${ED}/usr/share/metainfo" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}