summaryrefslogtreecommitdiff
path: root/app-text/openpaperwork-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /app-text/openpaperwork-core
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'app-text/openpaperwork-core')
-rw-r--r--app-text/openpaperwork-core/Manifest2
-rw-r--r--app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/openpaperwork-core/Manifest b/app-text/openpaperwork-core/Manifest
index 6e05d9d5ca8e..b59971b578f6 100644
--- a/app-text/openpaperwork-core/Manifest
+++ b/app-text/openpaperwork-core/Manifest
@@ -1,3 +1,5 @@
DIST openpaperwork-core-2.1.2.tar.gz 104694 BLAKE2B cf7cc132758662495d4b586efebccaa20c892cdca2ae3bb68d5fc45639c828b8441906c56067db079c12f1393adcd69d2edec19ca51fe5fcd5930ce2a7005c0c SHA512 88cb55b7b94e1e149042357d3a1c6c2a2184e4810b5895e02ef896554ae88ed0ebacd9c11e401da5e155aec857cd1b148328b1ffd0b760f939e4e97b96d1ce1a
+DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
EBUILD openpaperwork-core-2.1.2.ebuild 464 BLAKE2B 2fd7b5444a3f202bf3ebc74e7b59de5f1bdeb9a98e41a41a4bc662a72c93b5db926ef51820e8f3fa8ff9ed270b30ff011d2fbcb3a22182d881833f583195dea4 SHA512 7ebe9f6e6de60c9e72fb8ef830dc4102ac771e97c61d47cffbd09c070f2a2d0f6a8caa47166c325f71b2673511529403a93e8c67033fde848b523213d41b3c91
+EBUILD openpaperwork-core-2.2.1.ebuild 762 BLAKE2B 39d3c6399db004aed52f23431a5eb6923b71f20b7315a5183a80d0251d8c9471fbea3dbc0c2acc12f7cd0f369a5f39a091c4c288178804f3d788dde94bd3b35e SHA512 19171e8b671784aa33e6c2f6faeac2c803e404bd646c9b4c3ceefc45035f15afd06cac21f65d83824c50130fdee59539d1ec112c366aa9d0f324053e004048c4
MISC metadata.xml 411 BLAKE2B 3b2c93ec0ef42b0af9ef95f4ddaa408bccbcad56b10358ee781b828274e00fc309be763a3193e411ca0886f9a96450fb6a52a86bf796713408cc1fdccf743d59 SHA512 43487d9ab1dd7bf0076cbd43b55f3ac30c53ec05d16fd8250d344af06528be0bc9aae1099530c342239b795d98398c4154ce03b7f5354b09b2632db62e5a81b3
diff --git a/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild b/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild
new file mode 100644
index 000000000000..add748104564
--- /dev/null
+++ b/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core part of Paperwork (plugin management)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/distro[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-devel/gettext"
+
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}