summaryrefslogtreecommitdiff
path: root/app-text/ocrad/ocrad-0.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/ocrad/ocrad-0.22.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/ocrad/ocrad-0.22.ebuild')
-rw-r--r--app-text/ocrad/ocrad-0.22.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/ocrad/ocrad-0.22.ebuild b/app-text/ocrad/ocrad-0.22.ebuild
new file mode 100644
index 000000000000..289635030861
--- /dev/null
+++ b/app-text/ocrad/ocrad-0.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker toolchain-funcs
+
+DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
+HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="$(unpacker_src_uri_depends)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ # ./configure is not based on autotools
+ ./configure \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix=/usr
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ doinfo doc/${PN}.info
+}