summaryrefslogtreecommitdiff
path: root/app-text/nuspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
commit4f8c8df3b07b6ea3556ab2bc7b252213bbdab3f3 (patch)
treeda90388e25f27949d16131813690edb36c53aa81 /app-text/nuspell
parent413ca4e6c2089d8b5e0844c26cf5671209226b93 (diff)
gentoo auto-resync : 08:11:2023 - 22:21:23
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest2
-rw-r--r--app-text/nuspell/nuspell-5.1.4.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 32fd2662bf93..2e3f63ba69e3 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,3 +1,5 @@
DIST nuspell-5.1.3.tar.gz 371496 BLAKE2B 7a4aa05b01bd085e0612cf681783cfa2314a3b775c283f7e25c19d6afbb5af74c7ea2ffe149c68ca422383c24bd043e4b5e6b0895a0acd7c376e3d39f253a867 SHA512 72c868f734848be79c7cfb0502298626307213e4f3f422f8e9ee7dac24cb3d79ea55d04ef0443e7107bb11eb545c79a15a8aea8cb056dc2805c23bd5e3292562
+DIST nuspell-5.1.4.tar.gz 371512 BLAKE2B c1c05cc113cf7a6a4b77671f4fe372b2131a6cbcb328d76517bcbb45863e1fd0f27d76597193cae3a5c686d8e0b480fc831e0aa8dbcbf9f9b65420200a13d444 SHA512 f4119b3fe5944be8f5bc35ccff8d7a93b0f4fa9f129bc97a7b96879a11b5b35bd714b41dd209267417e94c5fed45fd3a74b349f94424f4b90bde07d9694d1d7d
EBUILD nuspell-5.1.3.ebuild 1122 BLAKE2B 26f2748dbaf1a961e44467de34a348739b7683c5adb8ca9beb13b9757b31388e0e8e0bc65df8a6ad2ae5ca74e3b2a13c5df9c5a4fbd3cea68f35edc5f446b5bd SHA512 01a54179b2184e62d1648a80a2a531825708891d551889a1b84d38d7c054609142ed33e78ee411fff65ad2e861436b0fb953366d7793840110c7127857937d34
+EBUILD nuspell-5.1.4.ebuild 1129 BLAKE2B 3f41d08680c445e24128b8006023c397a4723e48b14764909265177756dc53ec30f66066f05cfafa4956fd8168f4ef6b194f5cce8e094927295f2b0a58118ebf SHA512 7ae02257895b98642ac3922fc0c7bd45b49b4d0a72d006165a0fb0a9e1912835782bde191ecbe353b02c02811a2b5d7f7309aa017c40633f84cfe220fb439597
MISC metadata.xml 570 BLAKE2B 35d293be6eceb86ffb9b19a890b6fb280b0d81e29a9d3b648edddf35e4cc1f7986c04926ea570b6e3c6bba9b753bfccfa8728118da836b00633eaffe59fbd8f0 SHA512 08de4433355e1e8b059bcade466dbb8947b38700ee8cf96b7fd8c80d7fef9caf330a9294ba5a80b98dd986581e7b07bf6ae9b14d138477dbeca34d3dc8230edb
diff --git a/app-text/nuspell/nuspell-5.1.4.ebuild b/app-text/nuspell/nuspell-5.1.4.ebuild
new file mode 100644
index 000000000000..d0791bda1ad5
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( virtual/pandoc )
+ test? ( >=dev-cpp/catch-3.1.1:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}