summaryrefslogtreecommitdiff
path: root/app-text/nuspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-text/nuspell
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest2
-rw-r--r--app-text/nuspell/nuspell-3.1.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 856068c0104d..152f25ced7f4 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,3 +1,5 @@
DIST nuspell-3.0.0.tar.gz 403043 BLAKE2B b437012e4fb327f13d9ff0944dadf7e865c670daf153be00dd48e9d2fc01c87d410ebd5aeaa094f6446d3035346738010cdba961cfaada3751bedce264beaa6a SHA512 d9cd7dd276e2bca43dec3abaf11c5206695949b9fda8c9b86f2772cc7e8fa95bf17c685a2ef9ca87fe3c4f0b55f2fcb435bc21c187355f5e3fa35dcafab2c8c2
+DIST nuspell-3.1.0.tar.gz 407196 BLAKE2B 688f6f59ba2f7bceaafe9a7cc707c008be93341e855ca60f07d6de67a626539693048af6f5ca40246ccc51e2573b76ba2bd4439aa9c0acb66a212bebd9219617 SHA512 a9bedfd6e2d77fd34d249cf7aa1fcb6bde5bced26f02f8a2dd860416a61488c9b7016a0df6015052fcccb272b342e6205db601107f46efa44c9d78ce261a826c
EBUILD nuspell-3.0.0.ebuild 1091 BLAKE2B 07c8fa7a2b9c03c18821ccd35bc1d9fa5f72490c4a9ec4d52cd4f4f90cb2d295771e2110b6ab50ab8c0bb34db075349735993e61f3d5ddca1380d5cec4e467f8 SHA512 eceed5f031c930296ed451dad77718cd07e4b052598026b4c59219467eb26c7eb050239d1869339791bd9e4bf437af9e54cefa1981ffe939394331a5dde8adff
+EBUILD nuspell-3.1.0.ebuild 1152 BLAKE2B 0ab1b278f6423bcb16a3133fb7c2223bdd654e2757a15d606100794459c411e1703b0426f28edec6b32d767ad4c7071e6b4db5e0c6b1f2e0fab0085cb96cf671 SHA512 ef38093ed47b99964a263505cf3374e4390830b482464082154358c860e47988fb076da79304ad540121424e1f7345652f9f646ed595502fdea364fc833064e2
MISC metadata.xml 489 BLAKE2B 51835316b4f8b1b1a016324955d48f6f5126ef7b7caf11f4b46ea858469fc9ebe3154de4fbc99d528bfef3808fe7c95dd2f540038572ae640b00dad9fccbeacf SHA512 ea959020e4b2a90f475d296fd1a43c2ba8efc1c39f2dde70b930165bce165df1011e04af8f54b37740f28e009502a5c64ec0fdb2b7221003388cd47b1ccadeb5
diff --git a/app-text/nuspell/nuspell-3.1.0.ebuild b/app-text/nuspell/nuspell-3.1.0.ebuild
new file mode 100644
index 000000000000..84d7b5101d04
--- /dev/null
+++ b/app-text/nuspell/nuspell-3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="test? ( || ( MPL-1.1 GPL-2+ LGPL-2.1+ ) ) LGPL-3+"
+SLOT="0/3" # due to libnuspell.so.3
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ronn )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users . Good luck!'
+ einfo
+}