summaryrefslogtreecommitdiff
path: root/app-text/nfoview/nfoview-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /app-text/nfoview/nfoview-9999.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'app-text/nfoview/nfoview-9999.ebuild')
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
index 58b524bbcffb..f8030006af37 100644
--- a/app-text/nfoview/nfoview-9999.ebuild
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit distutils-r1 fdo-mime gnome2-utils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
- https://github.com/otsaloma/nfoview.git"
- inherit git-2
- SRC_URI=""
- #KEYWORDS=""
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
else
SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -24,7 +22,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE=""
-DEPEND="dev-python/pygobject:3"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
media-fonts/terminus-font"
@@ -34,10 +32,10 @@ pkg_preinst() {
pkg_postinst() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}