summaryrefslogtreecommitdiff
path: root/app-text/mupdf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-text/mupdf/files
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-text/mupdf/files')
-rw-r--r--app-text/mupdf/files/mupdf-1.14-CFLAGS.patch13
-rw-r--r--app-text/mupdf/files/mupdf-1.14-Makefile.patch46
-rw-r--r--app-text/mupdf/files/mupdf-1.14-openssl-curl-x11.patch52
3 files changed, 111 insertions, 0 deletions
diff --git a/app-text/mupdf/files/mupdf-1.14-CFLAGS.patch b/app-text/mupdf/files/mupdf-1.14-CFLAGS.patch
new file mode 100644
index 000000000000..90972e8c53ea
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.14-CFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/Makerules b/Makerules
+index fc9bf998..82f10b28 100644
+--- a/Makerules
++++ b/Makerules
+@@ -21,8 +21,6 @@ SANITIZE_FLAGS += -fsanitize=address
+ SANITIZE_FLAGS += -fsanitize=leak
+
+ ifeq ($(build),debug)
+- CFLAGS += -pipe -g
+- LDFLAGS += -g $(LDREMOVEUNREACH)
+ else ifeq ($(build),release)
+ CFLAGS += -pipe -O2 -DNDEBUG -fomit-frame-pointer
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s
diff --git a/app-text/mupdf/files/mupdf-1.14-Makefile.patch b/app-text/mupdf/files/mupdf-1.14-Makefile.patch
new file mode 100644
index 000000000000..a8c4ef770dce
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.14-Makefile.patch
@@ -0,0 +1,46 @@
+1. debug build (not sure why...)
+2. build shared library
+3. add optional static lib target
+4. Don't install COPYING
+diff --git a/Makefile b/Makefile
+index 37fc48e6..4303e9fa 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@
+ -include user.make
+
+ ifndef build
+- build := release
++ build := debug
+ endif
+
+ ifndef OUT
+@@ -190,13 +190,15 @@ generate: source/pdf/js/util.js.h
+
+ # --- Library ---
+
+-MUPDF_LIB = $(OUT)/libmupdf.a
+-THIRD_LIB = $(OUT)/libmupdf-third.a
++MUPDF_LIB = libmupdf.so.$(GENTOO_PV)
++MUPDF_STATIC = $(OUT)/libmupdf.a
++THIRD_LIB =
+ THREAD_LIB = $(OUT)/libmupdf-threads.a
+ PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
+
+-$(MUPDF_LIB) : $(MUPDF_OBJ)
+-$(THIRD_LIB) : $(THIRD_OBJ)
++$(MUPDF_LIB): $(MUPDF_OBJ) $(THIRD_OBJ)
++ $(QUIET_LINK) $(CC) $(LDFLAGS) --shared -Wl,-soname -Wl,$(MUPDF_LIB) -Wl,--no-undefined -o $@ $^ $(THIRD_LIBS) $(LIBS)
++$(MUPDF_STATIC): $(MUPDF_OBJ) $(THIRD_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
+
+@@ -355,7 +357,7 @@ install: libs apps
+
+ install -d $(DESTDIR)$(docdir)
+ install -d $(DESTDIR)$(docdir)/examples
+- install README COPYING CHANGES $(DESTDIR)$(docdir)
++ install README CHANGES $(DESTDIR)$(docdir)
+ install docs/*.html docs/*.css docs/*.png $(DESTDIR)$(docdir)
+ install docs/examples/* $(DESTDIR)$(docdir)/examples
+
diff --git a/app-text/mupdf/files/mupdf-1.14-openssl-curl-x11.patch b/app-text/mupdf/files/mupdf-1.14-openssl-curl-x11.patch
new file mode 100644
index 000000000000..a1284a63d670
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.14-openssl-curl-x11.patch
@@ -0,0 +1,52 @@
+diff --git a/Makerules b/Makerules
+index fc9bf998..5c0fffa4 100644
+--- a/Makerules
++++ b/Makerules
+@@ -113,10 +113,14 @@ else ifeq ($(OS),Linux)
+ SYS_ZLIB_LIBS := $(shell pkg-config --libs zlib)
+ endif
+
++ WANT_CURL ?= yes
++ ifeq "$(WANT_CURL)" "yes"
+ HAVE_CURL := $(shell pkg-config --exists libcurl && echo yes)
+ ifeq ($(HAVE_CURL),yes)
+ SYS_CURL_CFLAGS := $(shell pkg-config --cflags libcurl)
+- SYS_CURL_LIBS := $(shell pkg-config --libs libcurl)
++ # We have to forcibly add -lpthread to avoid linking errors.
++ SYS_CURL_LIBS := $(shell pkg-config --libs libcurl) -lpthread
++ endif
+ endif
+
+ HAVE_GLUT := yes
+@@ -125,17 +129,29 @@ else ifeq ($(OS),Linux)
+ SYS_GLUT_LIBS := -lglut -lGL
+ endif
+
++ WANT_X11 ?= yes
++ ifeq "$(WANT_X11)" "yes"
+ HAVE_X11 := $(shell pkg-config --exists x11 xext && echo yes)
+ ifeq ($(HAVE_X11),yes)
+ X11_CFLAGS := $(shell pkg-config --cflags x11 xext)
+ X11_LIBS := $(shell pkg-config --libs x11 xext)
+ endif
++ endif
+
+- HAVE_LIBCRYPTO := $(shell pkg-config --exists 'libcrypto >= 1.1.0' && echo yes)
+- ifeq ($(HAVE_LIBCRYPTO),yes)
++ WANT_OPENSSL ?= yes
++ ifeq "$(WANT_OPENSSL)" "yes"
++ ifeq "$(shell pkg-config --exists 'libcrypto >= 2.0.0' && echo libre)" "libre"
++ ifeq "$(shell pkg-config --exists 'libcrypto >= 2.7.0' && echo yes)" "yes"
++ HAVE_LIBCRYPTO := yes
++ LIBCRYPTO_CFLAGS := $(shell pkg-config --cflags libcrypto) -DHAVE_LIBCRYPTO
++ LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
++ endif
++ else ifeq "$(shell pkg-config --exists 'libcrypto >= 1.1.0' && echo yes)" "yes"
++ HAVE_LIBCRYPTO := yes
+ LIBCRYPTO_CFLAGS := $(shell pkg-config --cflags libcrypto) -DHAVE_LIBCRYPTO
+ LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
+ endif
++ endif
+
+ HAVE_PTHREAD := yes
+ ifeq ($(HAVE_PTHREAD),yes)