summaryrefslogtreecommitdiff
path: root/app-text/mupdf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-text/mupdf/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-text/mupdf/files')
-rw-r--r--app-text/mupdf/files/mupdf-1.19.0-Makefile.patch37
-rw-r--r--app-text/mupdf/files/mupdf-1.19.0-cross-fixes.patch130
-rw-r--r--app-text/mupdf/files/mupdf-1.19.0-darwin.patch39
3 files changed, 206 insertions, 0 deletions
diff --git a/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch b/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch
new file mode 100644
index 000000000000..b266655aaeca
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile b/Makefile
+index 7fa74b3..e842374 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@
+ -include user.make
+
+ ifndef build
+- build := release
++ build := debug
+ endif
+
+ default: all
+@@ -252,17 +252,19 @@ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
+ else
+-MUPDF_LIB = $(OUT)/libmupdf.a
++MUPDF_LIB = libmupdf.so.$(GENTOO_PV)
+ LIBS_TO_INSTALL_IN_LIB = $(MUPDF_LIB) $(THIRD_LIB)
+-THIRD_LIB = $(OUT)/libmupdf-third.a
++THIRD_LIB =
++MUPDF_STATIC = $(OUT)/libmupdf.a
+ ifneq ($(USE_SYSTEM_GLUT),yes)
+ THIRD_GLUT_LIB = $(OUT)/libmupdf-glut.a
+ endif
+ THREAD_LIB = $(OUT)/libmupdf-threads.a
+ PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
+
+-$(MUPDF_LIB) : $(MUPDF_OBJ)
+-$(THIRD_LIB) : $(THIRD_OBJ)
++$(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_OBJ)
++ $(QUIET_LINK) $(CC) $(LDFLAGS) --shared -Wl,-soname -Wl,$(MUPDF_LIB) -o $@ $^ $(THIRD_LIBS) $(LIBS)
++$(MUPDF_STATIC): $(MUPDF_OBJ) $(THIRD_OBJ)
+ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
diff --git a/app-text/mupdf/files/mupdf-1.19.0-cross-fixes.patch b/app-text/mupdf/files/mupdf-1.19.0-cross-fixes.patch
new file mode 100644
index 000000000000..643b6d2c8b1e
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.19.0-cross-fixes.patch
@@ -0,0 +1,130 @@
+Refreshed patches based on:
+https://sources.debian.org/patches/mupdf/1.17.0+ds1-1/0004-MuPDF-crossbuild-use-target-arch-pkg-config.patch/
+https://sources.debian.org/patches/mupdf/1.17.0+ds1-1/0005-MuPDF-crossbuild-use-host-cc-for-utils.patch/
+--- a/Makefile
++++ b/Makefile
+@@ -147,6 +147,9 @@ PKCS7_OBJ := $(PKCS7_SRC:%.c=$(OUT)/%.o)
+
+ HEXDUMP_EXE := $(OUT)/scripts/hexdump.exe
+
++$(HEXDUMP_EXE): scripts/hexdump.c
++ $(QUIET_CC) $(MKTGTDIR) ; $(CC_FOR_BUILD) $(CFLAGS) -o $@ $<
++
+ FONT_BIN := $(sort $(wildcard resources/fonts/urw/*.cff))
+ FONT_BIN += $(sort $(wildcard resources/fonts/han/*.ttc))
+ FONT_BIN += $(sort $(wildcard resources/fonts/droid/*.ttf))
+--- a/Makerules
++++ b/Makerules
+@@ -6,6 +6,9 @@ OS := $(OS:MSYS%=MINGW)
+ OS := $(OS:Windows_NT=MINGW)
+ OS := $(OS:Darwin=MACOS)
+
++PKG_CONFIG ?= pkg-config
++CC_FOR_BUILD ?= $(CC)
++
+ WARNING_CFLAGS := -Wall -Wsign-compare
+
+ # Feature configuration options
+@@ -156,51 +159,51 @@ else ifeq ($(OS),MACOS)
+ endif
+ endif
+
+- ifeq ($(shell pkg-config --exists freetype2 && echo yes),yes)
+- SYS_FREETYPE_CFLAGS := $(shell pkg-config --cflags freetype2)
+- SYS_FREETYPE_LIBS := $(shell pkg-config --libs freetype2)
++ ifeq ($(shell $(PKG_CONFIG) --exists freetype2 && echo yes),yes)
++ SYS_FREETYPE_CFLAGS := $(shell $(PKG_CONFIG) --cflags freetype2)
++ SYS_FREETYPE_LIBS := $(shell $(PKG_CONFIG) --libs freetype2)
+ endif
+- ifeq ($(shell pkg-config --exists gumbo && echo yes),yes)
+- SYS_GUMBO_CFLAGS := $(shell pkg-config --cflags gumbo)
+- SYS_GUMBO_LIBS := $(shell pkg-config --libs gumbo)
++ ifeq ($(shell $(PKG_CONFIG) --exists gumbo && echo yes),yes)
++ SYS_GUMBO_CFLAGS := $(shell $(PKG_CONFIG) --cflags gumbo)
++ SYS_GUMBO_LIBS := $(shell $(PKG_CONFIG) --libs gumbo)
+ endif
+- ifeq ($(shell pkg-config --exists harfbuzz && echo yes),yes)
+- SYS_HARFBUZZ_CFLAGS := $(shell pkg-config --cflags harfbuzz)
+- SYS_HARFBUZZ_LIBS := $(shell pkg-config --libs harfbuzz)
++ ifeq ($(shell $(PKG_CONFIG) --exists harfbuzz && echo yes),yes)
++ SYS_HARFBUZZ_CFLAGS := $(shell $(PKG_CONFIG) --cflags harfbuzz)
++ SYS_HARFBUZZ_LIBS := $(shell $(PKG_CONFIG) --libs harfbuzz)
+ endif
+- ifeq ($(shell pkg-config --exists lcms2 && echo yes),yes)
+- SYS_LCMS2_CFLAGS := $(shell pkg-config --cflags lcms2)
+- SYS_LCMS2_LIBS := $(shell pkg-config --libs lcms2)
++ ifeq ($(shell $(PKG_CONFIG) --exists lcms2 && echo yes),yes)
++ SYS_LCMS2_CFLAGS := $(shell $(PKG_CONFIG) --cflags lcms2)
++ SYS_LCMS2_LIBS := $(shell $(PKG_CONFIG) --libs lcms2)
+ endif
+- ifeq ($(shell pkg-config --exists libjpeg && echo yes),yes)
+- SYS_LIBJPEG_CFLAGS := $(shell pkg-config --cflags libjpeg)
+- SYS_LIBJPEG_LIBS := $(shell pkg-config --libs libjpeg)
++ ifeq ($(shell $(PKG_CONFIG) --exists libjpeg && echo yes),yes)
++ SYS_LIBJPEG_CFLAGS := $(shell $(PKG_CONFIG) --cflags libjpeg)
++ SYS_LIBJPEG_LIBS := $(shell $(PKG_CONFIG) --libs libjpeg)
+ endif
+- ifeq ($(shell pkg-config --exists libopenjp2 && echo yes),yes)
+- SYS_OPENJPEG_CFLAGS := $(shell pkg-config --cflags libopenjp2)
+- SYS_OPENJPEG_LIBS := $(shell pkg-config --libs libopenjp2)
++ ifeq ($(shell $(PKG_CONFIG) --exists libopenjp2 && echo yes),yes)
++ SYS_OPENJPEG_CFLAGS := $(shell $(PKG_CONFIG) --cflags libopenjp2)
++ SYS_OPENJPEG_LIBS := $(shell $(PKG_CONFIG) --libs libopenjp2)
+ endif
+- ifeq ($(shell pkg-config --exists zlib && echo yes),yes)
+- SYS_ZLIB_CFLAGS := $(shell pkg-config --cflags zlib)
+- SYS_ZLIB_LIBS := $(shell pkg-config --libs zlib)
++ ifeq ($(shell $(PKG_CONFIG) --exists zlib && echo yes),yes)
++ SYS_ZLIB_CFLAGS := $(shell $(PKG_CONFIG) --cflags zlib)
++ SYS_ZLIB_LIBS := $(shell $(PKG_CONFIG) --libs zlib)
+ endif
+
+- HAVE_SYS_LEPTONICA := $(shell pkg-config --exists 'lept >= 1.7.4' && echo yes)
++ HAVE_SYS_LEPTONICA := $(shell $(PKG_CONFIG) --exists 'lept >= 1.7.4' && echo yes)
+ ifeq ($(HAVE_SYS_LEPTONICA),yes)
+- SYS_LEPTONICA_CFLAGS := $(shell pkg-config --cflags lept)
+- SYS_LEPTONICA_LIBS := $(shell pkg-config --libs lept)
++ SYS_LEPTONICA_CFLAGS := $(shell $(PKG_CONFIG) --cflags lept)
++ SYS_LEPTONICA_LIBS := $(shell $(PKG_CONFIG) --libs lept)
+ endif
+
+- HAVE_SYS_TESSERACT := $(shell pkg-config --exists 'tesseract >= 4.0.0' && echo yes)
++ HAVE_SYS_TESSERACT := $(shell $(PKG_CONFIG) --exists 'tesseract >= 4.0.0' && echo yes)
+ ifeq ($(HAVE_SYS_TESSERACT),yes)
+- SYS_TESSERACT_CFLAGS := $(shell pkg-config --cflags tesseract)
+- SYS_TESSERACT_LIBS := $(shell pkg-config --libs tesseract)
++ SYS_TESSERACT_CFLAGS := $(shell $(PKG_CONFIG) --cflags tesseract)
++ SYS_TESSERACT_LIBS := $(shell $(PKG_CONFIG) --libs tesseract)
+ endif
+
+- HAVE_SYS_CURL := $(shell pkg-config --exists libcurl && echo yes)
++ HAVE_SYS_CURL := $(shell $(PKG_CONFIG) --exists libcurl && echo yes)
+ ifeq ($(HAVE_SYS_CURL),yes)
+- SYS_CURL_CFLAGS := $(shell pkg-config --cflags libcurl)
+- SYS_CURL_LIBS := $(shell pkg-config --libs libcurl)
++ SYS_CURL_CFLAGS := $(shell $(PKG_CONFIG) --cflags libcurl)
++ SYS_CURL_LIBS := $(shell $(PKG_CONFIG) --libs libcurl)
+ endif
+
+ HAVE_GLUT := yes
+@@ -209,16 +212,16 @@ endif
+ SYS_GLUT_LIBS := -lglut -lGL
+ endif
+
+ HAVE_X11 := not-unless-portage-tells-me
+ ifeq ($(HAVE_X11),yes)
+- X11_CFLAGS := $(shell pkg-config --cflags x11 xext)
+- X11_LIBS := $(shell pkg-config --libs x11 xext)
++ X11_CFLAGS := $(shell $(PKG_CONFIG) --cflags x11 xext)
++ X11_LIBS := $(shell $(PKG_CONFIG) --libs x11 xext)
+ endif
+
+ HAVE_LIBCRYPTO := not-unless-portage-tells-me
+ ifeq ($(HAVE_LIBCRYPTO),yes)
+- LIBCRYPTO_CFLAGS := $(shell pkg-config --cflags libcrypto) -DHAVE_LIBCRYPTO
+- LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
++ LIBCRYPTO_CFLAGS := $(shell $(PKG_CONFIG) --cflags libcrypto) -DHAVE_LIBCRYPTO
++ LIBCRYPTO_LIBS := $(shell $(PKG_CONFIG) --libs libcrypto)
+ endif
+
+ HAVE_PTHREAD := yes
diff --git a/app-text/mupdf/files/mupdf-1.19.0-darwin.patch b/app-text/mupdf/files/mupdf-1.19.0-darwin.patch
new file mode 100644
index 000000000000..a81c7a008e44
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.19.0-darwin.patch
@@ -0,0 +1,39 @@
+--- a/Makerules
++++ b/Makerules
+@@ -139,11 +139,11 @@ ifeq ($(OS),MINGW)
+ else ifeq ($(OS),MACOS)
+ HAVE_GLUT := yes
+ SYS_GLUT_CFLAGS := -Wno-deprecated-declarations
+- SYS_GLUT_LIBS := -framework GLUT -framework OpenGL
+- CC = xcrun cc
+- AR = xcrun ar
+- LD = xcrun ld
+- RANLIB = xcrun ranlib
++ SYS_GLUT_LIBS ?= -framework GLUT -framework OpenGL
++ CC ?= xcrun cc
++ AR ?= xcrun ar
++ LD ?= xcrun ld
++ RANLIB ?= xcrun ranlib
+
+ ifeq (, $(shell which pkg-config))
+ $(warning "No pkg-config found, install it for proper integration of libcrypto")
+@@ -154,9 +154,7 @@ else ifeq ($(OS),MACOS)
+ LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
+ endif
+ endif
+-
+-else ifeq ($(OS),Linux)
+- HAVE_OBJCOPY := yes
++endif
+
+ ifeq ($(shell pkg-config --exists freetype2 && echo yes),yes)
+ SYS_FREETYPE_CFLAGS := $(shell pkg-config --cflags freetype2)
+@@ -229,8 +227,6 @@ else ifeq ($(OS),Linux)
+ PTHREAD_LIBS := -lpthread
+ endif
+
+-endif
+-
+ # The following section has various cross compilation configurations.
+ #
+ # Invoke these as: