summaryrefslogtreecommitdiff
path: root/app-text/multitail/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
commit5d0c50eb490582cf1277e150ee5bb63a90b85aa6 (patch)
tree7204c80f526d36b5a4c7c6cd1339971b97636808 /app-text/multitail/files
parent13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (diff)
gentoo auto-resync : 22:11:2022 - 13:06:24
Diffstat (limited to 'app-text/multitail/files')
-rw-r--r--app-text/multitail/files/multitail-7.0.0-fix-clang16-build.patch34
-rw-r--r--app-text/multitail/files/multitail-7.0.0-fix-lto-type-mismatch.patch29
-rw-r--r--app-text/multitail/files/multitail-7.0.0-gentoo.patch32
3 files changed, 95 insertions, 0 deletions
diff --git a/app-text/multitail/files/multitail-7.0.0-fix-clang16-build.patch b/app-text/multitail/files/multitail-7.0.0-fix-clang16-build.patch
new file mode 100644
index 000000000000..1c706e0d0236
--- /dev/null
+++ b/app-text/multitail/files/multitail-7.0.0-fix-clang16-build.patch
@@ -0,0 +1,34 @@
+Clang16 will not suppert implicit int and implicit function declarations.
+This patch makes the source code ready for clang16.
+See also: https://bugs.gentoo.org/870412
+
+Bug: https://bugs.gentoo.org/874102
+
+This patch is already merged upstream, see: https://github.com/folkertvanheusden/multitail/pull/10
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/misc.c
++++ b/misc.c
+@@ -477,7 +477,7 @@ void heartbeat(void)
+ mydoupdate();
+ }
+
+-void do_check_for_mail()
++void do_check_for_mail(dtime_t time)
+ {
+ if (check_for_mail > 0 && mail_spool_file != NULL)
+ {
+diff --git a/misc.h b/misc.h
+index febf11a..5566519 100644
+--- a/misc.h
++++ b/misc.h
+@@ -1,5 +1,7 @@
++#import "mt.h"
++
+ void info(void);
+ void statistics_menu(void);
+ void heartbeat(void);
+-void do_check_for_mail();
++void do_check_for_mail(dtime_t time);
+ void store_statistics(proginfo *cur, dtime_t now);
diff --git a/app-text/multitail/files/multitail-7.0.0-fix-lto-type-mismatch.patch b/app-text/multitail/files/multitail-7.0.0-fix-lto-type-mismatch.patch
new file mode 100644
index 000000000000..6ad621dd540e
--- /dev/null
+++ b/app-text/multitail/files/multitail-7.0.0-fix-lto-type-mismatch.patch
@@ -0,0 +1,29 @@
+Fix mismatching declarations so build does not fail with -Werror=lto-type-mismatch
+
+Bug: https://bugs.gentoo.org/855017
+
+This patch is already merged upstream, see: https://github.com/folkertvanheusden/multitail/pull/10
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/globals.c
++++ b/globals.c
+@@ -81,7 +81,7 @@ double heartbeat_t = 0.0;
+ off64_t msf_prev_size = 0;
+
+ dtime_t msf_last_check = 0;
+-dtime_t mt_started;
++time_t mt_started;
+
+ pid_t children_list[MAX_N_SPAWNED_PROCESSES];
+ pid_t tail_proc = 0; /* process used by checker-proc */
+--- a/selbox.h
++++ b/selbox.h
+@@ -1,4 +1,6 @@
+-int selection_box(void **list, char *needs_mark, int nlines, char type, int what_help, char *heading);
++#include "mt.h"
++
++int selection_box(void **list, char *needs_mark, int nlines, selbox_type_t type, int what_help, char *heading);
+ int select_window(int what_help, char *heading);
+ proginfo * select_subwindow(int f_index, int what_help, char *heading);
+ char * select_file(char *input, int what_help);
diff --git a/app-text/multitail/files/multitail-7.0.0-gentoo.patch b/app-text/multitail/files/multitail-7.0.0-gentoo.patch
new file mode 100644
index 000000000000..5219334abbe0
--- /dev/null
+++ b/app-text/multitail/files/multitail-7.0.0-gentoo.patch
@@ -0,0 +1,32 @@
+Gentoo splits off tinfo from ncurses, so we need to ask pkg-config here what the user has on the system.
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/Makefile
++++ b/Makefile
+@@ -24,10 +24,10 @@ ifeq ($(PLATFORM),Darwin)
+ LDFLAGS+=-lpanel $(NCURSES_LIB) -lutil -lm
+ else
+ ifeq ($(UTF8_SUPPORT),yes)
+- LDFLAGS+=-lpanelw -lncursesw -lutil -lm
++ LIBS+=$(shell $(PKG_CONFIG) --libs ncursesw panelw) -lutil -lm
+ CPPFLAGS+=-DUTF8_SUPPORT
+ else
+- LDFLAGS+=-lpanel -lncurses -lutil -lm
++ LIBS+=$(shell $(PKG_CONFIG) --libs ncurses panel) -lutil -lm
+ endif
+ endif
+
+@@ -40,10 +40,10 @@ DEPENDS:= $(OBJS:%.o=%.d)
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(OBJS) -o multitail $(LIBS)
+
+ ccmultitail: $(OBJS)
+- ccmalloc --no-wrapper -Wextra $(CC) $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o ccmultitail $(LIBS)
+
+ install: multitail
+ mkdir -p $(DESTDIR)$(PREFIX)/bin