summaryrefslogtreecommitdiff
path: root/app-text/mecab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
commit3b882b15eed3bb219b5f340b63733c8cda643079 (patch)
treec84890953bd9a939137323d667a7762da89f0f0c /app-text/mecab
parent4d9aef45678c7cb55b24107642790224ab8c153b (diff)
gentoo auto-resync : 19:08:2023 - 15:38:48
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/Manifest2
-rw-r--r--app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch16
-rw-r--r--app-text/mecab/mecab-0.996-r2.ebuild60
3 files changed, 78 insertions, 0 deletions
diff --git a/app-text/mecab/Manifest b/app-text/mecab/Manifest
index 1ee152db798f..95b33c20c5d5 100644
--- a/app-text/mecab/Manifest
+++ b/app-text/mecab/Manifest
@@ -1,5 +1,7 @@
AUX mecab-0.98-iconv.patch 302 BLAKE2B 3644a66b1bdf9099ff0258a057c930c1b2e065836b0e6332211e4d04efbbf39da1de2788d90143826a1c9d887fcb63042e533864e746b7c385baea485cb93490 SHA512 c0dcaa8637f1c16a33bd4dd4007225a4f1ed3f0eebcda28dc7d92ec0a66ea16b5bdd956fb3a904af8070ce0ac2d6c9090b602b4705e73fac1100a845b3a756ce
+AUX mecab-0.996-clang-16-binary_function.patch 532 BLAKE2B 74aafcdb73e954ca2c409c6644444f1039fae3cf652bdfd16e1c2306c884dab7d22243303db7308a53933621bf4f0f81045c816ae9feff6776010651ed96a652 SHA512 d5cfbd9e419883a8f87d0409392a217bc5e93ea6d16d413b3ffff2d662c70170a5075b36cd3a8178c57753f9e511e9fcfa189d5321cb60735432d967a5c664d7
AUX mecab-0.996-clang-16-register.patch 3285 BLAKE2B ce5fc8bb953c617ad614216949e96961e264b588a34269495082bc44fe89c23bef06cc42c39579ca02004fa923621c32b859e481c7b09d87a065df49a539f662 SHA512 e79c294bf29c1bf5cf356aa70461000f0ed999c43d0069ae95716bb4fea5280f2415f911828b7510b114ad7952247dd68bbffacfec65dcbd77b22f8fc2a2d662
DIST mecab-0.996.tar.gz 1398663 BLAKE2B 97ea18a00c6f2284c994681631b84a572d244b741c8e30b5fdf5404b2bf80fdd4c724c803999955e36ee252e59e6644716dbdca55a6ffb2e4de52193d7f777bd SHA512 aca6d16f411b9ba9b6687242246aeb28ede6d6c6a9122d4a32da9d8e76e79b5f4af2c8e3b13ad9462b34e9d2994cbd9bbbedebac45609684db9b703da999577f
EBUILD mecab-0.996-r1.ebuild 1266 BLAKE2B 9fd202ec8988294d00cefb3cf5a17f45aacb306c8ac308f4c3f775a2ef2c33c64107993784481c545f829110e00c6f1aecf4ca69d746c519d166de634dbac1a1 SHA512 909e9336e764789c9aa9a8bb6d51095b0719e8c7b240529539615be3836e350133450eb6934815cf20d00fb30ec2cbf8f867c20cba3c5145fef3834ea7bc3598
+EBUILD mecab-0.996-r2.ebuild 1331 BLAKE2B f1cdbb10dad1f31e957bb086e5ddbb6c24a2c045e65d8ce010fda379106b73df7bcce41d2d54c6bdb54e3b5548920e81cd28feeb2bb16be07585cd34cfad3fd2 SHA512 64eff42945a3c4588f81a8d2c9cc70c8a13f678b58e9f5d9058c9d75e0690aa6125ebf891f4362645b51d986b988e9329240320552fb79e24cc659d98362eded
MISC metadata.xml 413 BLAKE2B e30f9d8b15a3ab4419d79cdafa6615e9d7d353b62732b4e5bb819396f22ad951d485317b1da5d36f7e471fed9037d6efc9753e7e0f26e0c6b73b4501f50e1fc9 SHA512 99d12f9ea78a09e7b4230b8520a18d3d8c8d8d99cf77703c8a0bdcf7df63f3de64e8cdf30df7d046f5e5f98d2113abcca9c25de7671edda51da1a4e6fbc530bd
diff --git a/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch b/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch
new file mode 100644
index 000000000000..5776cf5b2aa5
--- /dev/null
+++ b/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch
@@ -0,0 +1,16 @@
+Dropping usage of binary_function
+--- a/src/dictionary.cpp
++++ b/src/dictionary.cpp
+@@ -65,7 +65,11 @@ int progress_bar_darts(size_t current, size_t total) {
+ }
+
+ template <typename T1, typename T2>
+-struct pair_1st_cmp: public std::binary_function<bool, T1, T2> {
++struct pair_1st_cmp {
++ public:
++ using first_argument_type = bool;
++ using second_argument_type = T1;
++ using result_type = T2;
+ bool operator()(const std::pair<T1, T2> &x1,
+ const std::pair<T1, T2> &x2) {
+ return x1.first < x2.first;
diff --git a/app-text/mecab/mecab-0.996-r2.ebuild b/app-text/mecab/mecab-0.996-r2.ebuild
new file mode 100644
index 000000000000..078cd4f66a9d
--- /dev/null
+++ b/app-text/mecab/mecab-0.996-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="static-libs unicode"
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/gettext
+"
+DEPEND="virtual/libiconv"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ || (
+ app-dicts/mecab-ipadic[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.98-iconv.patch
+ "${FILESDIR}"/${PN}-0.996-clang-16-register.patch
+ "${FILESDIR}"/${PN}-0.996-clang-16-binary_function.patch
+)
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in
+ sed -i "s:/lib:/$(get_libdir):" ${PN}rc.in
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with unicode charset UTF-8)
+}
+
+src_install() {
+ default
+ find "${ED}" -name 'Makefile*' -delete || die
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+}