summaryrefslogtreecommitdiff
path: root/app-text/mecab/mecab-0.996.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:58:21 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:58:21 +0100
commit3811bc3072bf19e2be351d2c63f81532945c0f21 (patch)
tree52b4da2dd6e3e391c6d505db21bf24fbedd2cb6e /app-text/mecab/mecab-0.996.ebuild
parent741f84b9049559581fdb52d1f8b93b5105c1187b (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'app-text/mecab/mecab-0.996.ebuild')
-rw-r--r--app-text/mecab/mecab-0.996.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/app-text/mecab/mecab-0.996.ebuild b/app-text/mecab/mecab-0.996.ebuild
index 8485aa6743a1..bbe997169300 100644
--- a/app-text/mecab/mecab-0.996.ebuild
+++ b/app-text/mecab/mecab-0.996.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit autotools eutils
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
-HOMEPAGE="http://mecab.sourceforge.net/"
-SRC_URI="https://mecab.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
KEYWORDS="amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
@@ -22,12 +22,17 @@ PDEPEND="|| (
app-dicts/mecab-naist-jdic[unicode=]
)"
+PATCHES=( "${FILESDIR}"/${PN}-0.98-iconv.patch )
+HTML_DOCS=( doc/. )
+
src_prepare() {
+ default
sed -i \
-e "/CFLAGS/s/-O3/${CFLAGS}/" \
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
configure.in || die
- epatch "${FILESDIR}/${PN}-0.98-iconv.patch"
+
+ mv configure.{in,ac}
eautoreconf
}
@@ -39,8 +44,6 @@ src_configure() {
src_install() {
default
- dodoc AUTHORS README
- dohtml -r doc/*
-
- use static-libs || find "${ED}" -name '*.la' -delete
+ find "${ED}" -name 'Makefile*' -delete || die
+ use static-libs || find "${ED}" -name '*.la' -delete || die
}