summaryrefslogtreecommitdiff
path: root/app-text/mathtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-text/mathtex
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-text/mathtex')
-rw-r--r--app-text/mathtex/Manifest2
-rw-r--r--app-text/mathtex/mathtex-1.05.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/mathtex/Manifest b/app-text/mathtex/Manifest
index 56a312fee704..e278da46390f 100644
--- a/app-text/mathtex/Manifest
+++ b/app-text/mathtex/Manifest
@@ -1,3 +1,5 @@
DIST mathtex-1.04.zip 148443 BLAKE2B 6632d30536428f6f33fc13a2b5b38651f2ab7a938381166b79c009ab3d95788fc69e8ed824dae64dca00d32bb79ccd00a73b772f9aebc813d54fd6e0f18839f4 SHA512 4b299a6dc503a01d6be3182ad982e38c0b6d926f09a09bd5169f8ad2c947c020ad532b15146379b4bc2158cfceec4cb4a0b7bf902423e0a8ad9b0b0190a99601
+DIST mathtex-1.05.zip 161624 BLAKE2B 9812cfadcc5d47286afb86c6ad38f5bdf932ef39efad2228b04b3b39cbb7543f78be9d82cfa8bbfcc72c9f46fa1931e39aeb71e3abab865dcd60e4e9717e2377 SHA512 f116618de4264efdbccb122b0e9769bbe622f6300266284a96e65f37346c000364063f201b31554bde62a4a4e13c0c8f16d570dca359d3ef27bc0f7622af3715
EBUILD mathtex-1.04.ebuild 903 BLAKE2B 1b410976032bb2cd416333f8c0dfc6540578af989336cf8219eea36b3f358a08c4c95d0fde4bc6fb2dfbbb8ed7474986a0a4f1835e5555c1e2c4d10725ef0cfb SHA512 bec772a76171828bfba8344b0f2a9292ffa23b803011b0975f2b872b56c7755d285ee7ba06a82c763ce12d42832a098b8baf0d199b78ffddda89a4b6506a0d50
+EBUILD mathtex-1.05.ebuild 930 BLAKE2B 865707bc57b4c02acd053ebd2d66c5b7a78184a688f00b0e00d68f97c76332a3170c95b1c631a18bcc02fd4af78e303fbc2de68c4ef6e4f0902e29ef63081a84 SHA512 b57bc91f09aa20d35756e42728abd4124f472d52b58499d1c6c6563c3e3787221567f16ccd8bdb06b00f32c46b37c8aa09ae23a05047a451c482770ccf6c19b8
MISC metadata.xml 634 BLAKE2B e034340d471f0aa802b1b874659596fa57e4447c362fb14e99a1efb1dd056da0de19a31fc8b175c58937d5dee2dc52e24a0c76ce0854f654b97fddcae43987e1 SHA512 6e8f077a6641b87fbf52f2d75ab67c4bf5a8389ccd4fae334d3e4d48af771e1acc380a222f720c939cb153277e1355e2ccf1cfea1728daaf89f6a54fd7facfab
diff --git a/app-text/mathtex/mathtex-1.05.ebuild b/app-text/mathtex/mathtex-1.05.ebuild
new file mode 100644
index 000000000000..9f8ebe064542
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.05.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="https://www.ctan.org/pkg/mathtex"
+SRC_URI="https://mirrors.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="png"
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ $(use png && echo "-DPNG") \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex
+ dodoc README mathtex.html
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}