summaryrefslogtreecommitdiff
path: root/app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
commit0da5c40f264673f79a9d8c95d465d1cab718d282 (patch)
treecf498476cd0085b71f73a02d2570c770c9023337 /app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild
parentdfa2037f41649c9775d690a3d01cfd5cabf4db71 (diff)
gentoo auto-resync : 15:02:2023 - 20:02:26
Diffstat (limited to 'app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild
new file mode 100644
index 000000000000..69d1eed91eb1
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.9.35.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5.x86_64.tar.gz"
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ sys-libs/glibc
+ >=dev-qt/qtcore-5.12.9:5
+ >=dev-qt/qtgui-5.12.9:5
+ >=dev-qt/qtnetwork-5.12.9:5
+ >=dev-qt/qtprintsupport-5.12.9:5
+ >=dev-qt/qtsvg-5.12.9:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="opt/${PN}/masterpdfeditor5"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}