summaryrefslogtreecommitdiff
path: root/app-text/libxmlpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libxmlpatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libxmlpatch')
-rw-r--r--app-text/libxmlpatch/Manifest4
-rw-r--r--app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch56
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild40
-rw-r--r--app-text/libxmlpatch/metadata.xml8
4 files changed, 108 insertions, 0 deletions
diff --git a/app-text/libxmlpatch/Manifest b/app-text/libxmlpatch/Manifest
new file mode 100644
index 000000000000..ee72e7d6b6a7
--- /dev/null
+++ b/app-text/libxmlpatch/Manifest
@@ -0,0 +1,4 @@
+AUX libxmlpatch-0.3.3-gentoo.patch 2029 BLAKE2B a2cced2f4a6e8c7ad53420e1c8a6d244cfc808ae398ecd4106b59c0c80c6d3b708a9bd7c6ccddd21f15b5a000faeba4d00d9510ed1eb3b4a44a34cf79e52905d SHA512 076f5ce303fa410ed48828bfd4c9544d4606511597bf39676a899fb577bc4670db83706ef05928d9e49a665089864d6fb2e22321c19217ed341265d57d2c4052
+DIST libxmlpatch-0.3.3.tar.gz 405496 BLAKE2B 57333f62b95be3acc058593ccdb935148217f84acd7b5d431043cf08bc217d04abe650be099a849790400f0153523cea46905e9a12e6a33e80f0e20edc2fd9f3 SHA512 2eb305ddd6aa1778bc9c9e7b8cae5f82ee05c0ed0a47bbb651209c496fff68f4e527b7d6ad1808bc8bf1f72aaa0172a12ddb140622ce87e3cd150a0ec4d35571
+EBUILD libxmlpatch-0.3.3.ebuild 772 BLAKE2B cdc29331635b6f5e8c227343b510d4ae94bcffdf6d70f0e8894710b11a9e53a630990c49cef28a37eb4b0c5524d61baf6a199733366828b1828e77ea7842dac8 SHA512 9087aa0c074e6c7b11b58bd02a6f8c19ba8d8c6730712a3157808de30b4064956caa862bdf31a7127b7772b6b7deef46597aa3d63cd197a0579bd9694a283f02
+MISC metadata.xml 245 BLAKE2B e5b503817d886ea642301a8fb76459f31236d1496ba03cb467126419460106072424b6da1e1957ffaf977ac05f4c4baacef448cdf86ea4cbd93fdba026d5e8af SHA512 f884111cb1a85bb4e909b8bc6a70ca00e8d69e066fc9ef79ddbf0b3fc277bc8a47ce13bc1b7bd03a4be9bc0a54704440552394f1d1a8c68d0bf9704b8f05769f
diff --git a/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
new file mode 100644
index 000000000000..a18104fb12b5
--- /dev/null
+++ b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
@@ -0,0 +1,56 @@
+Index: libxmlpatch-0.3.3/tests/check_diff.c
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/check_diff.c
++++ libxmlpatch-0.3.3/tests/check_diff.c
+@@ -259,7 +259,13 @@ static struct {
+ static void
+ add_test (TCase *tc, int i)
+ {
+- _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name, 0, 0, 1);
++ _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name,
++#if CHECK_MAJOR_VERSION > 0 || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION > 9) || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION == 9 && CHECK_MICRO_VERSION >= 7)
++ 0,
++#endif
++ 0, 0, 1);
+ }
+
+ static void
+Index: libxmlpatch-0.3.3/configure.in
+===================================================================
+--- libxmlpatch-0.3.3.orig/configure.in
++++ libxmlpatch-0.3.3/configure.in
+@@ -74,7 +74,13 @@ fi
+
+ PKG_CHECK_MODULES(DEPS_XML, libxml-2.0)
+ PKG_CHECK_MODULES(DEPS_GLIB, glib-2.0)
+-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
++
++AC_ARG_WITH([check],
++ AS_HELP_STRING([--without-check], [Do not build tests based on check package @<:@default=auto@:>@]))
++AS_IF([test "x$with_check" != "xno"], [
++PKG_CHECK_MODULES([CHECK], [check >= 0.9.4], , [with_check=no])
++])
++AM_CONDITIONAL([TESTS], [test "x$with_check" != "xno"])
+
+ AC_SUBST(DEPS_XML_CFLAGS)
+ AC_SUBST(DEPS_XML_LIBS)
+Index: libxmlpatch-0.3.3/tests/Makefile.am
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/Makefile.am
++++ libxmlpatch-0.3.3/tests/Makefile.am
+@@ -1,10 +1,11 @@
++if TESTS
+ TESTS = test-diff
++check_PROGRAMS = test-diff
++endif
+
+-test_PROGRAMS = test-diff
+ test_diff_SOURCES = check_diff.c
+ test_diff_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/diff @CHECK_CFLAGS@ $(DEPS_XML_CFLAGS) $(DEPS_GLIB_CFLAGS)
+ test_diff_LDADD = @CHECK_LIBS@ $(top_builddir)/src/libxmlpatch.la $(top_builddir)/diff/libxmldiff.la $(DEPS_XML_LIBS) $(DEPS_GLIB_LIBS)
+-testdir = $(libdir)/tests/xml_diff
+
+ bin_PROGRAMS = xml_patch xml_diff
+
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
new file mode 100644
index 000000000000..f5697fc876de
--- /dev/null
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
+HOMEPAGE="http://xmlpatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with test check)
+}
+
+DOCS=( LEGAL_NOTICE README TODO ChangeLog )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete
+}
diff --git a/app-text/libxmlpatch/metadata.xml b/app-text/libxmlpatch/metadata.xml
new file mode 100644
index 000000000000..ddc9bcf76f3d
--- /dev/null
+++ b/app-text/libxmlpatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">xmlpatch</remote-id>
+ </upstream>
+</pkgmetadata>